How to install the GeoSpatial extension for Talend

Overview

The GeoSpatial extension allows you to transform and integrate data between Geographic Information Systems. It consists of several components that can be added to the Studio and will extend Talend's capabilities toward geospatial information and bridge robust Open Source geospatial libraries for efficient data management.

 

Environment

You can download the GeoSpatial extension for Talend at the following address:
http://talend-spatial.github.io/

Select the extension corresponding to your Talend product version.

 

Description

The GeoSpatial extension consists of several components that need to be added to the Studio.

Installation procedure for TOS products

  1. Download the Spatial module http://sourceforge.net/projects/sdispatialetl/files/sdispatialetl/.
  2. Unzip the Spatial module.
  3. Copy the content of the plugin directory into the plugins directory of TOS.
  4. Start TOS.

Installation procedure for Talend version 5.3.1 (you will need to use TOS Spatial 5.3.1)

  1. Stop the studio.
  2. Copy and paste the content of SDI plugins into STUDIO_HOME/plugins.
  3. Create a text file named extrabundles.info and copy it into STUDIO_HOME/configuration/org.talend.configurator.
  4. Restart the Studio.

Content of the file named extrabundles.info

#version=1
org.talend.libraries.sdi,5.3.1,plugins/org.talend.libraries.sdi_5.3.1,4,true
org.talend.sdi.designer.components,5.3.1,plugins/org.talend.sdi.designer.components_5.3.1,4,true
org.talend.sdi.designer.components.sandbox,5.3.1,plugins/org.talend.sdi.designer.components.sandbox_5.3.1,4,true
org.talend.sdi.designer.routines,5.3.1,plugins/org.talend.sdi.designer.routines_5.3.1,4,true
org.talend.sdi.repository.ui.actions.metadata,5.3.1,plugins/org.talend.sdi.repository.ui.actions.metadata_5.3.1,4,true
org.talend.sdi.repository.ui.actions.metadata.ogr,5.3.1,plugins/org.talend.sdi.repository.ui.actions.metadata.ogr_5.3.1,4,true
org.talend.sdi.workspace.spatial,5.3.1,plugins/org.talend.sdi.workspace.spatial_5.3.1,4,true
Version history
Revision #:
13 of 13
Last update:
‎04-13-2017 07:11 PM
Updated by:
 
Labels (1)
Tags (1)
Comments
engttc

Hello,

 

Is there a version of the GeoSpatial extension that works for Talend 6.3 and above?

I am able to get the GeoSpatial extension working for Talend 6.0.1, but nothing higher.

 

thank you,

agershenson

Hi,

You might want to ask this question on one of the Community Discussion boards. If that doesn't get you an answer, you can contact Support at https://www.talend.com/services/technical-support/.

Hope that helps,

Alyce