I cannot open my newly-installed Talend Studio

Overview

In a Windows environment, a newly-installed Studio won't launch, and an error is displayed. It points to a file named XXXXXXXXXXXX.log.

 

Symptoms/Description

An extract of the lines that can be found in the log file:

 

!SESSION 2014-03-25 09:33:35.334 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.equinox.app 0 0 2014-03-25 09:33:38.287
!MESSAGE Product org.talend.rcp.branding.generic.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2014-03-25 09:33:38.975
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-25 09:33:38.975
!MESSAGE Bundle reference:file:plugins/org.eclipse.emf.mwe2.runtime_1.0.1.v201008251113.jar was not resolved.
!SUBENTRY 2 org.eclipse.emf.mwe2.runtime 2 0 2014-03-25 09:33:38.975
!MESSAGE Missing imported package org.apache.log4j_1.2.15.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-25 09:33:38.975
!MESSAGE Bundle reference:file:plugins/org.talend.designer.components.localprovider_5.3.1.r104014/ was not resolved.
!SUBENTRY 2 org.talend.designer.components.localprovider 2 0 2014-03-25 09:33:38.975
!MESSAGE Missing required bundle org.apache.log4j_0.0.0.
!SUBENTRY 2 org.talend.designer.components.localprovider 2 0 2014-03-25 09:33:38.975
!MESSAGE Missing required bundle org.apache.commons.collections_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-25 09:33:38.975
!MESSAGE Bundle reference:file:plugins/org.talend.designer.brms_5.3.1.r104014/ was not resolved.
!SUBENTRY 2 org.talend.designer.brms 2 0 2014-03-25 09:33:38.975
!MESSAGE Missing required bundle org.talend.libraries.jibx_0.0.0.
!SUBENTRY 2 org.talend.designer.brms 2 0 2014-03-25 09:33:38.975
!MESSAGE Missing required bundle org.apache.commons.collections_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-25 09:33:38.975
....
....
!ENTRY org.eclipse.osgi 4 0 2014-03-25 09:33:39.202
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
    at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
    at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

 

Resolution

Talend binaries need to be unzipped using the 7-Zip File manager. The error described in this article can occur if WinZip (for example) was used to unzip, as it does not handle long file names well.

Version history
Revision #:
9 of 9
Last update:
‎04-22-2017 02:57 AM
Updated by:
 
Labels (1)
Tags (1)