Requiring a JDK installation to build jobs starting from version 6.0

Overview

Starting from version 6.0, Talend Studio requires a JDK installation instead of just a JRE to build jobs, and you must configure the JDK path in Windows > Preferences > Java > Installed JRES.

 

Environment

  • Talend Studio starting from v6.0
  • Refer to the Compatible Platforms and Java Environments section of the Talend installation documentation for your Talend product version to select the correct JDK version. This article uses JDK 8 to demonstrate how to configure the JDK path in Talend Studio.

 

Symptoms/Resolution

Staring from version 6.0, a Wrong Java setup dialog pops up whenever Talend Studio starts up, as seen below:

Java_setup.png

 

You are required to install a JDK on your machine where Talend Studio is installed, and you must configure the JDK path in Window > References > Java > Installed JRES in Talend Studio before you build jobs. Otherwise, the target archive file will not be created.

Assuming the JDK installation path is C:\Program Files\Java\jdk1.8.0_45 follow these steps to configure the JDK path in Talend Studio:

  1. Click Windows, then Preferences, expand Java, and then click Installed JRES.
  2. Click Add to install a new JRE, or click Edit to edit an existing JRE. Browse to the location where your JDK8 is installed.

    install_jre.png

  3. Click OK to validate your change and close the window.

 

Conflicts between installed JRE/JDKs

If you have several Java installations, make sure to remove the JREs in the Preferences > Installed JREs window, to avoid the JRE taking precedence over the JDK.

Version history
Revision #:
2 of 2
Last update:
‎06-22-2017 08:32 PM
Updated by:
 
Labels (1)
Tags (1)