Demos using MySQL are not working [resolved]

Employee

Demos using MySQL are not working [resolved]

Hello, 

 

Due to the update of the MySQL Docker image, the container that is pulled in the sandbox has an issue. As they modified the parameters needed, the container is no longer working with the parameters provided.

 

Please use this hot fix to use the sandbox :

 

If you have chosen Cloudera distribution modify the following file :

 

/opt/talend/Docker/Cloudera-compose.yml

If you have chosen Hortonworks, modify the Hortonworks-compose.yml in the same folder.

 

Replace the mysql section with :

 

 

  mysql:
    dns: 172.17.0.1
    dns_search: weave.local.
    environment:
    - MYSQL_DATABASE=sandbox
    - MYSQL_USER=sandbox
    - MYSQL_PASSWORD=sandbox
    - MYSQL_ROOT_PASSWORD=first1
    hostname: mysql.weave.local
    image: mysql:5.7
    networks:
    - weave

The only modification is the tag "5.7" instead of "latest".

 

Once you've done that run the following commands :

sudo docker-compose -f ~/.dkr/compose/cluster1/docker-compose.yml rm -f mysql
sudo docker-compose -f ~/.dkr/compose/cluster1/docker-compose.yml down
reboot

The sandbox should restart with the good MySQL container version and the demos should be working again.

 

Please let us know if it has fixed the issue for you.

 

PS : Also, be aware that we are working on a new release of the sandbox with new demos and updated distributions, and we will make sure this issue won't happen again.

Employee

Re: Demos using MySQL are not working [resolved]

I also had to do the following command before rebooting.

docker pull mysql:5.7
Seven Stars

Re: Demos using MySQL are not working [resolved]

Hi, 

 

Does Hive also has same issue? Coz Hive connections are also not working. Is there any such HotFix for Hive?