Migration, Configuration, and Administration

Talend Support doesn't recommend dynamic synchronization of TAC DBs.
View full article
Fix the configuration errors or replace the component.
View full article
Modify the regular expression to allow special characters in the username.
View full article
Configure the .bashrc script or the environment variables.
View full article
Create a new hosted repository in a new environment and add the files.
View full article
An expired license prevents the CommandLine from starting.
View full article
Make the Job run longer, up to 10 seconds or more.
View full article
Apply patch TPS-2259 to fix this problem.
View full article
Specify URLs for TAC1 and TAC2 in configuration.properties.
View full article
Add useSSL=false to establish a non-SSL connection between TAC and the MySQL server.
View full article
Add MaxBackupIndex to the Elasticsearch log configuration file.
View full article
Set the Direct3D acceleration to false.
View full article
Go back to the version prior to the Talend update.
View full article
The JVN parameters must be HTTP, not HTTPS.
View full article
Intermittent bug, a patch is available.
View full article
Use JAVA_HOME or JDK_HOME, not JRE.
View full article
Ensure the table collation and character encoding are set correctly.
View full article
Talend Version          6.2.1 Summary How to enable Log4j level trace when launching a Job on a JobServer from Talend Studio. Additional Versions   Key words Talend Studio log4j JobServer trace level Product Talend Data Integration Component Studio Article Type Configuration Problem Description When executing a job locally from Talend Studio, the log4j trace level can be set in the Run View by clicking the Run tab Advanced settings, then checking the log4jLevel box and choosing the trace level. As a result, the Job log4j messages will be displayed according to the log4j trace level you set for a local Studio Talend job execution.   However, when executing a job remotely on a Jobserver from Talend Studio, the log4j messages won't be displayed according to the trace level you set in the Run View. You need to enable the log4j trace to a level so that when launching a job from Talend Studio on a Jobserver, you will be able to see the log4j trace in the Jobserver logs as well as in the local Talend Studio. Problem root cause   Solution or Workaround When a job launched from Talend Studio is executed on a Jobserver, the log4j configuration can be set by performing the following steps in Talend Studio: Click File > Project properties > Log4j. Set the trace level in this configuration by changing the priority value: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE log4j:configuration SYSTEM "log4j.dtd"> <log4j:configuration xmlns:log4j='http://jakarta.apache.org/log4j/' > .... <!-- Root Logger --> <root> <priority value ="trace"/> <appender-ref ref="CONSOLE"/> <!-- <appender-ref ref="LOGSTASH"/> --> </root> </log4j:configuration> The log4j level here is set to trace level. Click OK and Save. When running the job, you should get the trace on the Jobserver with the log4j level set, as well as in Talend Studio Run View. JIRA ticket number  
View full article
Add transportMode=http;httpPath=cliservice to the Hive connection properties.
View full article
Top Contributors