Using different versions of Oracle DB in the same Job, results in an 'ORA-28040: No matching authentication protocol' error

Problem Description

A Job, executed in 5.6.1, is using different versions of Oracle DB in the same Job, for example reading a table from an Oracle 12 database and writing to an Oracle 10 database table, results in the following error message and is displayed in the diagram below:

 

ORA-28040: No matching authentication protocol

oracle12oracle10.png

The stack trace captured while running the Job is shown below:

 

ora-28040.JPG

 

Solution

To resolve the issue, replace the ojdbc14.jar file with the ojdbc6.jar or ojdbc7.jar file accordingly.

 

In the current scenario, as the product version is 5.6.1, you can replace the .JAR files within Studio, in the STUDIO-dir\configuration\lib\java folder.

 

For more information, see the Stack Overflow page ORA-28040: No matching authentication protocol exception.

Version history
Revision #:
7 of 7
Last update:
‎04-13-2019 12:35 PM
Updated by: