Unable to publish Job due to application/XML file

Problem Description

When a Job is published to Nexus, or is run locally, it will error out, saying there was an error building the Job. Upon checking the logs, the following error is presented:

 

Caused by: javax.ws.rs.client.ClientException: .Problem with writing the request message, class : class java.security.DigestInputStream, ContentType : application/xml.
	at org.apache.cxf.jaxrs.client.AbstractClient.reportMessageHandlerProblem(AbstractClient.java:761)
	at org.apache.cxf.jaxrs.client.AbstractClient.writeBody(AbstractClient.java:448)
	at org.apache.cxf.jaxrs.client.WebClient$BodyWriter.doWriteBody(WebClient.java:1160)
	... 71 more
Caused by: java.net.ConnectException: Connection refused: connect

 

Root Cause

When this issue appears in Studio, it may mean that there was something on the CommandLine (remote) side that is not syncing up with the Studio and Nexus connection.

 

Solution

Check the connection between the remote CommandLine and Studio first to make sure it is correct and valid. If you're unsure where to go, navigate to Window > Preferences > Talend > Run/Debug. For details, see Distant run configuration (Talend > Run/Debug) in the Talend Data Integration Studio User Guide.

 

If the CommandLine settings are correct, then a restart of the remote CommandLine itself is needed. Restart the remote CommandLine, restart Studio (if needed), and then the Job can be published/remotely built.

 

Note: Clearing the CommandLine workspace when restarting the CommandLine may also be needed, as the communication issue could have caused bad code to reside in the CommandLine workspace.

Version history
Revision #:
4 of 4
Last update:
‎05-08-2018 03:28 PM
Updated by:
 
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