Trying to select Job name or version in Job Conductor or Publisher, but nothing pops up

Problem Description

In Job Conductor and Publisher, if I try to add a new task, when I get to the portion of selecting a Job, it says loading and disappears immediately. My Repository Browser also does not show any Jobs that I can select. Furthermore, if I try to run a Job, it errors out with a null argument. I also see that in the Job Conductor, there are parentheses () around all of my Job names and version numbers.

 

Root Cause

The root cause of this issue is that TAC has been disconnected from the repository, either SVN or Git. The tell-tale sign of this is that there are parentheses () around the Job names and also the version numbers. The repository browser not seeing any Jobs is another key evidence of this.

 

Solution

The caching most likely got corrupted somehow and thus disconnected the repo from TAC. There are two quick workarounds to try to solve the problem, and one more time-consuming resolution.

 

Workarounds

There are two easy workarounds that you can try:

  1. Restart TAC to see if it reestablishes the connection automatically.
  2. If that doesn't work, open Studio and move one component of a Job to another spot and then save it. Sometimes this will also reestablish the connection from the repo to TAC .

 

If these two workarounds do not solve the problem, see the resolution below.

 

Resolution

  1. Stop TAC.
  2. Clear the work and temp directories within TAC, usually located as shown below though use the path appropriate for your environment:

    C:/Talend/6.4.1/tac/apache-tomcat/work
    C:/Talend/6.4.1/tac/apache-tomcat/temp
  3. Rebuild the TAC cache. It will take some time to rebuild all of the temporary files, however this should resolve the issue.
Version history
Revision #:
7 of 7
Last update:
‎02-12-2018 03:51 PM
Updated by: