Trigger status is not resetting properly in TAC

Problem Description

You have several Jobs where the Job status is Ready to run, but the Trigger status is Waiting for the task to end. You have to run an SQL command to change the Trigger status from blocked to waiting on the backend.

 

What causes the Trigger status not to update, and can it be resolved?

 

Root Cause

This error can occur for various reasons; common possibilities are:

  • The Job fails and cannot revert its status or when some files in the workspace are not accessible.

  • The CommandLine is started under different OS user accounts.

  • A corrupted version of a project, Job, or dependencies is in the commandline-workspace directory, preventing the CommandLine from generating the Job.

  • The CommandLine is not started, or is not running properly.

Review the CommandLine and TAC logs for details. In this case, the following error message, indicates that there were problems with the triggers, misfired triggers, and the scheduler had to recalculate the next trigger start time (based on the policy set in case of misfired trigger), and that next start time is after the end time set for that trigger:

2018-05-10 12:26:04 ERROR TaskExecutionHistoryBusiness - End time cannot be before start time
java.lang.IllegalArgumentException: End time cannot be before start time
at org.quartz.CronTrigger.setEndTime(CronTrigger.java:536)
at org.quartz.TriggerUtils.computeFireTimesBetween(TriggerUtils.java:1312)

 

Solution

To resolve this issue, performing the following:

  1. Stop TAC.

  2. Navigate to the apache-tomcat folder.

  3. Delete the contents in both the work and temp folders.
  4. Then restart TAC.

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  1. Stop CommandLine in the folder: TALEND_HOME\cmdline\studio\configuration.
  2. Delete your commandLine-workspace that is located in the CommandLine root directory. For example, talend/6.x.x/dev/tac/cmdline/studio/commandline-workspace.

  3. Then restart your CommandLine service.

Version history
Revision #:
8 of 8
Last update:
‎04-14-2019 02:21 AM
Updated by:
 
Comments
Employee

I think this can also happen with this error if the job server has a time that is earlier than that of the TAC. You can adjust the timestamp of the job server to match the TAC time under servers page of TAC and set the time to TAC server time. 

Six Stars

Question for Talend Team - can you provide some insight regarding the relationship between the tac tables.  Especially between the native Talend tables and the QRTZ tables?  I am not able to find any documentation regarding this.