How to resolve scaling issues with high resolution screens for Windows OS

Problem Description

When installing Talend Studio on systems with high resolution screens, the icons are not displaying properly, and Studio becomes unusable.

 

Solution

  1. Copy and paste the following content into a text editor, such as Notepad:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide] 
    "PreferExternalManifest"=dword:00000001
  2. Give the file a name, for example, Prefer External Manifest, then save it with the file extension .reg. Make sure you don't save it as a .txt file!

    Note: Only one key is added to the registry, and it tells Windows to prefer external app scaling setting.

  3. Double-click the registry file you just created, then select Yes in the pop-up window.

  4. Navigate to the folder containing the Studio executable, Talend-Studio-win-x86_64.

  5. Copy and paste the following content into a text editor, such as Notepad:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    
    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    
    <dependency>
    <dependentAssembly>
    <assemblyIdentity
    type="win32"
    name="Microsoft.Windows.Common-Controls"
    version="6.0.0.0" processorArchitecture="*"
    publicKeyToken="6595b64144ccf1df"
    language="*">
    </assemblyIdentity>
    </dependentAssembly>
    </dependency>
    
    <dependency>
    <dependentAssembly>
    <assemblyIdentity
    type="win32"
    name="Microsoft.VC90.CRT"
    version="9.0.21022.8"
    processorArchitecture="amd64"
    publicKeyToken="1fc8b3b9a1e18e3b">
    </assemblyIdentity>
    </dependentAssembly>
    </dependency>
    
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
    <security>
    <requestedPrivileges>
    <requestedExecutionLevel
    level="asInvoker"
    uiAccess="false"/>
    </requestedPrivileges>
    </security>
    </trustInfo>
    
    <asmv3:application>
    <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
    <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>
    </asmv3:windowsSettings>
    </asmv3:application>
    
    </assembly>
    
    
  6. Save the file as, Talend-Studio-win-x86_64.exe.manifest, in the same folder as the Studio executable file.

    Note: The extension of the file is .manifest.

  7. Open the Studio application.

For a demonstration and if you would prefer to download publicly available files, see the YouTube video How to Fix App Scaling Surface Pro 4 + Other High DPI Displays.

Version history
Revision #:
15 of 15
Last update:
‎04-13-2019 12:40 PM
Updated by:
 
Comments
Employee

Hi @hmaram @psmith,

Could you guys please suggest how can we achieve this one for studio running in Linux?

Thanks

Four Stars

Try these compatibility settings:

 

talend screen resolution.png