Cannot establish a connection between TAC and Nexus (timeout occurs when retrieving parameter)

Problem Description

Although the Nexus service is up and running, and the Nexus credentials in TAC are correct, you cannot establish a connection between TAC and the Artifact Repository Nexus. The common line in the error log (nexus.log), is similar to the following:

Too many open files.
Result of "service service_name status": inactive.

 

Root Cause

The default user limit is set for the talenduser.

 

Solution

Check the user limit on the Linux server with ulimit -n; the default is 1024. Increase ulimit (user limit) to unlimited, by performing the following steps:

  1. Edit the /etc/security/limits.conf file, for example:

    talenduser soft  nofile    65535
    talenduser hard  nofile    65535
    
    talenduser soft  nproc     65535  
    talenduser hard  nproc     65535
  2. Save the limits.conf file.

  3. Log in again (close all active sessions) to see the changes.

Note: in this example, the talenduser is the OS user who starts the Talend services and who owns all the files in Talend installation folders.

Version history
Revision #:
5 of 5
Last update:
‎04-10-2019 05:17 AM
Updated by:
 
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