trove.jar problem with manual installation of jboss-serialization.jar

Four Stars Jon
Four Stars

trove.jar problem with manual installation of jboss-serialization.jar

I am behind a corporate firewall, so I install all external modules manually.

While creating a job, the External modules popup told me that I was missing a few jars.

The first one was jboss-serialization.jar, so I downloaded it, unzipped it and installed it manually.

Then when I tried to run my job the external modules screen told me that I needed trove.jar

I downloaded and tried installing various versions of trove.jar from various repositories on the net.

None of them worked. The external Modules screen was still telling me to install trove.jar.

Then I went back to the local disk subdirectory where I had unzipped jboss-serialization.jar and noticed (at last) that there was a second jar hiding in there, called (yes, you guessed it) trove.jar.

I installed that version manually and my problem went away.

Clearly, there is something special about the version which arrives inside the same zip file as jboss-serialization.jar.

 

 

 

Moderator

Re: trove.jar problem with manual installation of jboss-serialization.jar

Hello,

Thanks for sharing your case about the hidden jar files with us on forum.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads