One Star

[resolved] routines not expanding / visible

Hi all,
im having a issue with TOS data integration (5.5.0 r117820)
yesterday all was ok.
today my routines are not available anymore......when i click code--> routines : the routines are not showing/not expanding.
if i create a new one with a name of a existing routine(although not showing) i get an error of "This item already exists....."
also in business model, Job designs....all items in the repository when i "choose export" items no option appears.
i can expand jobdesigns, contexts , code(expands -> routines. nothing more)
sqltemplates,metadata.....
is my workspace messed up?
any help is appreciated.
6 REPLIES
Fifteen Stars

Re: [resolved] routines not expanding / visible

Check your Recycle Bin in the project tree. Sometimes you can mistakenly hit delete (I've even seen it happen without any evidence of anyone hitting delete) and the objects will end up there. You can restore them from there if that is where they are.
Rilhia Solutions
One Star

Re: [resolved] routines not expanding / visible

the routines are there , only not visible, im not able to expand//collapse.
my recicle bin is empty.
im able to use routines . i cannot see the routines, but im using them in some jobs.im running a job right now with a routine....jus to test...
i alreay clicked "refresh".
already closed talend, reboot maching. started talend , the issue remains.
also in business model, Job designs....all items in the repository when i choose "export items" no option appears.
i can expand jobdesigns, contexts , code(expands -> routines. nothing more)
sqltemplates,metadata.....
any help is appreciated.
Fifteen Stars

Re: [resolved] routines not expanding / visible

If it were me I would install another version of Talend Studio, copy your old workspace to a new location and then point the new installation to the copy of the old workspace. That might enable you to get your work back. If it does, take an export to save it.
I've seen workspaces get corrupted and I've seen Studio installations get corrupted. It is difficult to tell which is happening here. If you get the same result, it is likely the workspace that is corrupted. If that is the case you might fix it by importing your old workspace into a new workspace using the import tool. Instead of importing a zip file, import the folder structure.
Rilhia Solutions
One Star

Re: [resolved] routines not expanding / visible

thank you very much.
"
copy your old workspace to a new location and then point the new installation to the copy of the old workspace. That might enable you to get your work back. If it does, take an export to save it." -> you mean the folder workspace?
ill try that tomorow and let you know how it went.
Fifteen Stars

Re: [resolved] routines not expanding / visible

Yes, the "workspace" folder inside your Studio folder.... assuming you have not renamed it or used something other than the default.
Rilhia Solutions
One Star

Re: [resolved] routines not expanding / visible

hi rhall_2.0,
thank you for your feedback on this issue.
just a liltle feedback on this issue now that its solved
i exported  the "bussiness models" that contain all my jobs + routines + etc...
 i installed tos6 and imported the jobs + routines, but then the issue remains..^^
i think that one of the routines was corrupted, this meant that i could not export jobs, expand routines...
i proceed  to try to find the corrupted routine, export routines in tos5, import them in tos6.
i leaved out one routine in particular that i created this week.
im now able to export all items in tos6.
im able to expand routines.
problem solved!
thank you once again. this was a tricky one.