One Star

[resolved] W8 installation - demo priorTest failure

Hello
I am a beginner for TOS.
On an "old" XP PC, with JRE 1.6, no trouble. I manage to realize first steps (launch, demo installation, job launch of priorTest and beforeRunJobs, with modification of context).
But on a new PC :
- W8 PRO
- JDK 32 bits : C:\Program Files (x86)\Java\jdk1.8.0
- JAVA_HOME : C:\Program Files (x86)\Java\jdk1.8.0
- "Talend Open Studio for Data Integration" : Version: 5.4.1 / Build id: r111943-20131212-1133
TOS DI launching is OK : TOS_DI-win32-x86.exe, and installation of DEMO is OK also.
But, priotTest launching gives a failure :
///////////////////////////////////////////////////////////////////////////////////////////
Exécution en erreur :Échec de la génération du code.

/////////////////////////////////////////////////////////////////
What may be wrong ?
8 REPLIES
Moderator

Re: [resolved] W8 installation - demo priorTest failure

Hi,
Have you checked online document about TalendHelpCenter:Compatible Platforms? Could you please try to use jdk 1.7 instead of jdk 1.8 to see if it is working?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] W8 installation - demo priorTest failure

Hi,
Have you checked online document about TalendHelpCenter:Compatible Platforms? Could you please try to use jdk 1.7 instead of jdk 1.8 to see if it is working?
Best regards
Sabrina

Hello Sabrina,
Thank you for this instantaneous response.
I need to keep my existing JDK installation (1.8) in place for other applications.
question 1 : How can I tell TOS to use another JDK ?
question 2 : Modifying the .ini ?
Concerning JDK version, on compatible platform web pages I can read :
Microsoft Windows / 8.1 / 64-bit / Oracle Java 7 / supported
question 3 : but for 8.1 PRO, is it the same ?
question 4 : which JDK 7 : 32 or 64 bits ?
I am no very familiar with java installation :
question 5 : should the JRE 1.7 be sufficient ?
question 6 : should I install also the JDK ?
Thank you for your support.
Community Manager

Re: [resolved] W8 installation - demo priorTest failure

Hi jjmonot
You could have more than one JVM installation on your machine, and specify another JVM to launch Talend Studio for a particular purpose. Refer to this KB article:
https://www.linkedin.com/pulse/20141106140303-15611760-specify-different-jvm-to-launch-talend-open-s...
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Moderator

Re: [resolved] W8 installation - demo priorTest failure

Hi,
question 3 : but for 8.1 PRO, is it the same ?
question 4 : which JDK 7 : 32 or 64 bits ?

In the documentation we provide a list of platforms that are supported, in the sense that we do provide an SLA and technical support for them. This doesn't mean other (non-listed) platforms will not work but simply we won't necessarily be equipped to help you with any issue you may face with them.
question 5 : should the JRE 1.7 be sufficient ?
question 6 : should I install also the JDK ?

You should install JDK. There might be some unknown exception if you only use JRE.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] W8 installation - demo priorTest failure

Hello
Now it works.
What I have done :
1. check that no other application requires java JDK8 or JRE8
2. remove installation of java JDK8 and JRE8
3. install JDK7 (55) for 32 and 64 bits
4. install TOS DI in C:\TalendOpenStudio\
5. create TOS32.bat file to launch 32 bits version of TOS DI with -vm option to JRE7 32 bits version
TOS_DI-win32-x86.exe -vm "C:\Program Files (x86)\Java\jdk1.7.0_55\jre\bin"
6. launch TOS DI with the TOS32.bat
Launch of priorTest job : OK
beforeRunJobs :
1. modification of context :
root : C:\TalendOpenStudio\TOS_DI-Win32-r111943-V5.4.1\workspace\ESSAIDEMO32\documentations
workspace : C:\TalendOpenStudio\TOS_DI-Win32-r111943-V5.4.1\workspace
2. launch of the job : OK
Conclusion : TOS DI is currently not compatible with java JDK8
Hope it helps ...
Four Stars

Re: [resolved] W8 installation - demo priorTest failure

Hi jjmonot,
Thanks for this useful update.
Vaibhav
One Star

Re: [resolved] W8 installation - demo priorTest failure

Little correction (\ was missing ...)
root : C:\TalendOpenStudio\TOS_DI-Win32-r111943-V5.4.1\workspace\ESSAIDEMO32\documentations\
workspace : C:\TalendOpenStudio\TOS_DI-Win32-r111943-V5.4.1\workspace\
Moderator

Re: [resolved] W8 installation - demo priorTest failure

Hi jjmonot,
Thanks for sharing your useful information with us.
So far, talend does not support for Java 8.
Here is a KB article about TalendHelpCenter:Java 8 Support.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.