[resolved] Talend IDE scaling issue on HiDPI screen

One Star

[resolved] Talend IDE scaling issue on HiDPI screen

Hi,
I have a new Dell XPS13" with HiDPI display, Windows 10. All icons in Eclipse based Talend IDE are un-readable, seems to be a scaling issue. Does anybody have solution for this please?

Thanks,
Jan

Accepted Solutions
One Star

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Hi jhorak,
I have the same problem on mu XPS15. The solution I found (https://jaxenter.com/netbeans/hidpi-with-eclipse-and-netbeans) with these type of applications that don't handle HiDPI (like Eclipse) can be solved as follows on Windows 10. It's not optimal becasue some popup's etc. are still not very readable, but at least you can work with these programms.
First you need to add (or change) the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD)

Give this the value of 1.
Then create a .manifest file in the same directory as the .exe. For instance for Talend DI on Win 64 name the file "TOS_DI-win-x86_64.exe.manifest". Copy the below contents and save the file.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    <description>eclipse</description>
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
        <security>
            <requestedPrivileges>
                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"
                               level="asInvoker"
                               ms_asmv3:uiAccess="false">
                </requestedExecutionLevel>
            </requestedPrivileges>
        </security>
    </trustInfo>
    <asmv3:application>
        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>
        </asmv3:windowsSettings>
    </asmv3:application>
</assembly>


Now when you start DI it should give you a workable screen.
Regards,
Pierre

All Replies
Moderator

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Hi,
I have a new Dell XPS13" with HiDPI display, Windows 10. All icons in Eclipse based Talend IDE are un-readable, seems to be a scaling issue

Could you please upload your error screenshot into forum?]
Have you already checked document about:TalendHelpCenter:Compatible Platforms and Java environments?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Hi jhorak,
I have the same problem on mu XPS15. The solution I found (https://jaxenter.com/netbeans/hidpi-with-eclipse-and-netbeans) with these type of applications that don't handle HiDPI (like Eclipse) can be solved as follows on Windows 10. It's not optimal becasue some popup's etc. are still not very readable, but at least you can work with these programms.
First you need to add (or change) the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD)

Give this the value of 1.
Then create a .manifest file in the same directory as the .exe. For instance for Talend DI on Win 64 name the file "TOS_DI-win-x86_64.exe.manifest". Copy the below contents and save the file.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    <description>eclipse</description>
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
        <security>
            <requestedPrivileges>
                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"
                               level="asInvoker"
                               ms_asmv3:uiAccess="false">
                </requestedExecutionLevel>
            </requestedPrivileges>
        </security>
    </trustInfo>
    <asmv3:application>
        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>
        </asmv3:windowsSettings>
    </asmv3:application>
</assembly>


Now when you start DI it should give you a workable screen.
Regards,
Pierre
Four Stars

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Thanks Pierre, this worked for me like a charm!
Regards,
Dennis
One Star

Re: [resolved] Talend IDE scaling issue on HiDPI screen

This is still a problem in Ubuntu (16.04). It's due to underlying eclipse. Newer versions of eclipse have fixed the problem but I guess whatever Talend is built on is too old. I've been searching but no good solutions

.
Moderator

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Hi bruka,
Did you get this issue when using talend latest released version 6.3? So far, we are using eclipse luna 4.4.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Sabrina,
I downloaded the latest version from your website. I have attached the install configuration details. I also tried these switches which I found from online search but they didn't seem to have any effect:
-Dswt.autoScale=200
-Dswt.autoScale.method=nearest

talend.config.txt.txt
One Star

Re: [resolved] Talend IDE scaling issue on HiDPI screen

Seems this might be a java runtime issue and have nothing to do with Talend or eclipse. I have only recently switched to Ubuntu from OSX and only now noticing these kinds of issues. JDK 9 is supposed to have fixes for it.
https://bugs.openjdk.java.net/browse/JDK-8055212