[resolved] TOS 5.4.0 Startup Error

One Star

[resolved] TOS 5.4.0 Startup Error

Hi,
After installing the required modules into <install-dir>/lib/java the TOS 5.4.0 crashes at next startup with the following log entry:
!SESSION 2013-11-13 16:26:18.781 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data C:\Workspaces\talend-di
!ENTRY org.eclipse.equinox.registry 2 0 2013-11-13 16:27:51.512
!MESSAGE The extensions and extension-points from the bundle "org.talend.libraries.esb" are ignored. The bundle is not marked as singleton.
!ENTRY org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.pde.ui.nl_it_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ui.nl_it 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.pde.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.equinox.launcher.gtk.linux.s390.nl_ja_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.s390.nl_ja 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.s390_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.equinox.launcher.wpf.win32.x86.nl_ru_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.wpf.win32.x86.nl_ru 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.equinox.launcher.wpf.win32.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.pde.ds.ui.nl_zh_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ds.ui.nl_zh 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.pde.ds.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.pde.ui.nl_zh_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ui.nl_zh 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.pde.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-11-13 16:27:53.411
!MESSAGE Bundle update@plugins/org.eclipse.pde.ds.ui.nl_es_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ds.ui.nl_es 2 0 2013-11-13 16:27:53.411
!MESSAGE Missing host org.eclipse.pde.ds.ui_0.0.0.

...
...
...
!ENTRY org.eclipse.osgi 4 0 2013-11-13 16:27:53.515
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Cannot change the location once it is set.
at org.eclipse.core.runtime.internal.adaptor.BasicLocation.set(BasicLocation.java:136)
at org.eclipse.core.runtime.internal.adaptor.BasicLocation.set(BasicLocation.java:131)
at org.eclipse.core.runtime.internal.adaptor.BasicLocation.setURL(BasicLocation.java:124)
at org.talend.rcp.intro.Application.acquireWorkspaceLock(Application.java:222)
at org.talend.rcp.intro.Application.start(Application.java:63)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

Happens anytime I do a fresh "Installation" (Extraction) and then install the required JARs.
Any suggestions?
BR
Stefan

Accepted Solutions
One Star

Re: [resolved] TOS 5.4.0 Startup Error

???
I removed the "-data <workspace_location>" entry from the shortcut and then it worked again.
curious...

All Replies
One Star

Re: [resolved] TOS 5.4.0 Startup Error

???
I removed the "-data <workspace_location>" entry from the shortcut and then it worked again.
curious...
One Star

Re: [resolved] TOS 5.4.0 Startup Error

HI
You need to install JDK and set up environment variable (like JAVA_HOME and Path)
Have a nice day!
One Star

Re: [resolved] TOS 5.4.0 Startup Error

I removed the "-data <workspace_location>" entry from the shortcut and then it worked again.
curious...

BR
Stefan
One Star

Re: [resolved] TOS 5.4.0 Startup Error

where can I locate  "-data <workspace_location>"?