[resolved] Problem installing Talend DI on RHEL 7

One Star

[resolved] Problem installing Talend DI on RHEL 7

Steps I have followed 
1. Created directory /home/<user>/Talend
2. Extracted TOS_DI-20141207_1530-V5.6.1 to : TOS_DI-20141207_1530-V5.6.1 in Talend dir
3. Extracted xulrunner-1.9.2.28pre.en-US.linux-x86_64.tar.bz2 to xulrunner in Talend dir
4. Installed eclipse 4.4.1 in /opt/eclipse & added below two lines to eclipse.ini 
-Dorg.eclipse.swt.browser.DefaultType=mozilla
org.eclipse.swt.browser.DefaultType=mozilla
5. Installed Java /usr/lib/jvm/jdk1.7.0_75
java version "1.7.0_75"
OpenJDK Runtime Environment (rhel-2.5.4.2.el7_0-x86_64 u75-b13)
OpenJDK 64-Bit Server VM (build 24.75-b04, mixed mode)
export JAVA_HOME=/use/lib/jvm/jdk1.7.0_75/
export PATH=$JAVA_HOME:$PATH
6. added -Dorg.eclipse.swt.browser.XULRunnerPath=/home/<user>/Talend/xulrunner/
to TOS_DI-linux-gtk-x86_64.ini
chmod +x TOS_DI-linux-gtk-x86
./TOS_DI-linux-gtk-x86_64
I'm getting JRE RunTime errors
A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f0e082f8877, pid=39406, tid=139698948179712
# JRE version: OpenJDK Runtime Environment (7.0_75-b13) (build 1.7.0_75-mockbuild_2015_01_16_09_12-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.75-b04 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea 2.5.4
# Distribution: Built on Red Hat Enterprise Linux Server release 7.0 (Maipo) (Fri Jan 16 09:12:28 EST 2015)
# Problematic frame:
# C    gdk_window_enable_synchronized_configure+0x7
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Please advise.

Accepted Solutions
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

Finally it worked!
For others who are still facing issues in getting Talend to work with their linux machine please read all above posts; Check if you have not missed any steps & finally you would need to install xming server for windows to SSH tunnel you output from linux server to windows machine 
Few final steps
 
Install Xming-6-9-0-31-setup
Install Xming-fonts-7-5-0-70-setup
Open PuTTY > SSH > X11 > enable X11 Forwarding > Session > load your session 
execute ./TOS_DI-linux-gtk-x86_64 from directory where TOS_DI-20141207_1530-V5.6.1 is installed. And output would appear on your windows machine
PS - make sure you have installed xauth package use yum install xauth. Also make sure that version of JDK you r using is not OpenJDK. you can install oracle version of JDK & select default Java version to be used (follow steps from this blog - digitalocean dot com how-to-install-java-on-centos-and-fedora)  

All Replies
Seventeen Stars

Re: [resolved] Problem installing Talend DI on RHEL 7

Is eclipse running correctly or has only the Open Studio this problem?
If you would have some trouble with the xulrunner, this would not affect the start of the studio. It would prevent some dialogs from working and the start screen would be empty.
Moderator

Re: [resolved] Problem installing Talend DI on RHEL 7

Hi, 
So far, talend don't support for OpenJDK. Could you please use Oracle JDK instead to see if it is working?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

My apologies for not mentioning this.. I did see your response to others that it does not support OpenJDK & in fact I have installed jdk1.7.0_75 & have set environment variables (mentioned below) but still when i try to run it is picking up OpenJDK. Please advise
export JAVA_HOME=/usr/lib/jvm/jdk1.7.0_75/bin/java
export PATH=$PATH:/usr/lib/jvm/jdk1.7.0_75/bin 
export JDK_HOME=/usr/lib/jvm/jdk1.7.0_75
export JRE_HOME=/usr/lib/jvm/jre-1.7.0
Moderator

Re: [resolved] Problem installing Talend DI on RHEL 7

Hi,
Can you uninstall Open JDK? Have you already checked document about: TalendHelpCenter:TalendOpenStudioforDataIntegrationInstallationandUpgradeGuide55EN/1.1 Installation ... and TalendHelpCenter:Compatible Platforms?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

Instead of installing (since other apps might be using OpenJDK, I have run these commands) 
sudo alternatives --install /usr/bin/java java /usr/lib/jvm/jre1.7.0_71/bin/java 1
sudo alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_75/bin/java 1
sudo alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.7.0_75/bin/javac 1
sudo alternatives --install /usr/bin/jar jar /usr/lib/jvm/jdk1.7.0_75/bin/jar 1
Now I see different error (Not related to OpenJDK).. then I tried running eclipse & I get below mentioned error
Error: Could not find or load main class org.eclipse.swt.browser.DefaultType=mozilla
** (eclipse:9562): WARNING **: Could not open X display
Eclipse: Cannot open display:
Eclipse:
JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-Dorg.eclipse.swt.browser.DefaultType=mozilla org.eclipse.swt.browser.DefaultType=mozilla
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

@jlolling I have not been able to run eclipse I installed "X Window system" I appreciate your guidance please help me run Talend on RHEL 7 
Now when I run eclipse I get
** (java:60333): WARNING **: Could not open X display
Eclipse: Cannot open display:
org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized.  Will retry after the state location is initialized.
** (eclipse:60332): WARNING **: Could not open X display
Eclipse: Cannot open display:
Eclipse:
An error has occurred. See the log file
/opt/eclipse/configuration/1426626811183.log.
Seventeen Stars

Re: [resolved] Problem installing Talend DI on RHEL 7

You need perhaps a bit more Linux skill. Perhaps you switch back to Windows, looks you are more familiar with it.
A user need the rights to open an X display, an display must be configured (DISPLAY variable).
If you have no experiences, I suggest you install an desktop oriented Linux distribution with Gnome.
I would install eclipse with the package management from the red head repositories. This way you will be sure to avoid missing packages.
Same procedure for Java.
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

Thanks jlolling! I'm acquiring necessary skills.. brushing up on Linux skills I had not been using Linux box for few years now... 
fact is I have to do it on current RHEL box.. I have already installed analytic suite & PostgreSQL & now was trying to complete architecture by installing open source ETL to feed my analytics data mart. 
Thank you for pointers.. Your help is highly appreciated!  
One Star

Re: [resolved] Problem installing Talend DI on RHEL 7

Finally it worked!
For others who are still facing issues in getting Talend to work with their linux machine please read all above posts; Check if you have not missed any steps & finally you would need to install xming server for windows to SSH tunnel you output from linux server to windows machine 
Few final steps
 
Install Xming-6-9-0-31-setup
Install Xming-fonts-7-5-0-70-setup
Open PuTTY > SSH > X11 > enable X11 Forwarding > Session > load your session 
execute ./TOS_DI-linux-gtk-x86_64 from directory where TOS_DI-20141207_1530-V5.6.1 is installed. And output would appear on your windows machine
PS - make sure you have installed xauth package use yum install xauth. Also make sure that version of JDK you r using is not OpenJDK. you can install oracle version of JDK & select default Java version to be used (follow steps from this blog - digitalocean dot com how-to-install-java-on-centos-and-fedora)  
Moderator

Re: [resolved] Problem installing Talend DI on RHEL 7

Hi sumitc,

Great it is fixed. Could you please mark this topic as resolved so that other community user will be informed that this thread has been resolved.

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.