One Star

[resolved] Probelm with Installation of Data Integration under Windows 8

Hello,
I'm trying to install Talend Data Integration "TOS_DI-Win32-20141024_1545-V5.6.0.exe" but without success. For preparation of installation
-> installed JDK7 (jdk1.7.0_80)
-> set the environment variable java_home on Java 7 (C:\Program Files (x86)\Java\jdk1.7.0_80) 
-> extracted the files to root (C:\Talend\5.5.1)
-> in the new directory I deployed the exe file "TOS_DI-win32-x86.exe". However I received the following error message:
>>> The Studio does not support Java 8. Java 7 is the recommended JVM version to used.
Under the Talent Help Center "" I could not find any other solution(s).
My Question is:
does Talent Open Studio work generally under Windows 8.1 Pro? Or I need actually Windows 7 or another proper os?
Thank you very much for your soon support.
Best regards,
Wahid
1 ACCEPTED SOLUTION

Accepted Solutions
Seventeen Stars

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

check JAVA_HOME and PATH variables in environment variables
do it for environment not for system (for java_home the repository where jdk7 is installed , for path add the sub directory bin to your path)

you can also try to modify the talend .ini file & add -vm (jvm argument) to point to your jdk 7 home directory
it should work ... Smiley Happy
regards
laurent
8 REPLIES
Seventeen Stars

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

hi,
as your message error is said : java 8 is not supported 
you have to downgrade to java 7.
what's return 'java --version' in cmd ?
regards
laurent
One Star

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

Hi,
Good idea. I lunched java RE in control panel and found two items:
Under User-Tabpage:
- platform 1.8
- Platform 1.7
Under System - Tabpage:
- platform 1.8
As I remember Windows 8 uses the JRE 1.8. So I cannot deactivate 1.8. How can I avoid this 1.8 version?
Thanx,
Wahid
Six Stars

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

You can deactivate/activate JRE's through the Java control panel. Also make sure the Java 1.8 is not contained in your PATH variable.
Moderator

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

Hi,
Please take a look at:https://help.talend.com/search/all?query=Compatible+Platforms&content-lang=en
Check your current JDK version by "java -version" in cmd.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

Hi,
Thank you for your support. I checked the java version and this is the return: java version "1.8.0_25". Before this step I removed the flag for java 1.8 under the java control panel for jre and windows plattform (and rebooted os afterwards). However it does not work.
I installed Talend Enterprise under OS Win7 Enterprise and all is fine. Any assumption?
Thanx and regards,
Wahid
Seventeen Stars

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

check JAVA_HOME and PATH variables in environment variables
do it for environment not for system (for java_home the repository where jdk7 is installed , for path add the sub directory bin to your path)

you can also try to modify the talend .ini file & add -vm (jvm argument) to point to your jdk 7 home directory
it should work ... Smiley Happy
regards
laurent
One Star

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

Hi,
Thank you. Because of number of problems I removed Java_8 from the HD and left Java_7 on os(Win 8). Afterwards it works without any problems.
Regards,
Wahid
Moderator

Re: [resolved] Probelm with Installation of Data Integration under Windows 8

Hi Wahid,
Can we consider this topic as resolved?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.