[resolved] No Application ID Error

One Star

[resolved] No Application ID Error

I have been trying to install Talend Studio 5.2.1 and I keep getting an error when trying to run the application (32 bit).
Here is the error from the log file generated:
!ENTRY org.eclipse.osgi 4 0 2014-06-05 16:55:44.337
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
I have uninstalled all of my Java and reinstalled it and this error is still occurring. Any thoughts on what might be causing the error?
Chris

Accepted Solutions
Moderator

Re: [resolved] No Application ID Error

Hi,
It is probably caused by blank space or long installation path. Thanks for your feedback. Could you please mark this topic as resolved? Let us know if there is any further help we can give.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: [resolved] No Application ID Error

Hi,
What's your OS and JDK version? Does this issue repro on other versions(5.5.0, 5.4.1...)?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] No Application ID Error

My OS is Windows 7 and I've got JDK 1.7.0_060 installed (32 bit and 64 bit versions). I have not tried it with any other versions as our development server is running 5.2.1. I'm just trying to install it as a client.
Moderator

Re: [resolved] No Application ID Error

Hi,
Have you tried to run 64 bit application to see if this issue occur?
In addition, Window 7 64 bit should be consistent with JDk 64 bit, the same to Window 7 32 bit(JDK 32bit).
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] No Application ID Error

Unfortunately the 64 bit version returns pretty much the same result:
!ENTRY org.eclipse.osgi 4 0 2014-06-11 22:26:42.879
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
Moderator

Re: [resolved] No Application ID Error

Hi,
You are using talend open studio?(For talend enterprise subscription, a expired license may cause this issue)
It will occur error if there is some blank space in installation path or the problem is probably due to long path.
Did you try to reinstall it in another folder and restart it?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] No Application ID Error

Well after the fifth uninstall and reinstall it finally seems to have taken. No idea why this was being so difficult.
Moderator

Re: [resolved] No Application ID Error

Hi,
It is probably caused by blank space or long installation path. Thanks for your feedback. Could you please mark this topic as resolved? Let us know if there is any further help we can give.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.