One Star

[resolved] Mac Install : unable to locate its companion shared library

Hi,
just downloaded Talend for multiple OS
Unzipped it
tried to launch TalendOpenStudio-macosx-carbon
then I get the following message in a popup window:
"The TalendOpenStudio-macosx-carbon executable launcher was unable to locate its companion shared library"
I'm running on a MacBookAir2010, JVM 1.6 update 24
I precise that, months ago, it used to work (I don't remember the version unfortunately)
Any idea?
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

I just downloaded TOS_DI-20161026_1219-V6.3.0 and receive error message:
The TOS_DI-macosx-cocoa executable launcher was unable to locate its companion shared library.
when I click on TOS_DI-macosx-cocoa.app
I had your previous open studio version installed and was working correctly.  I tried all the steps above.  I did not have eclipse installed, so installed the most recent version. I've added 
/Users/krw/eclipse/java-neon/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
to the ini file.  Still receive same message.  I did not have another file in that directory to add the 2nd line if the above example.
Please advise.
13 REPLIES
Community Manager

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi
Please read the related 2831.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi
I'm having the same problem and unfortunately I was unable to resolve it using the solution in the link; I chmod'ed both the .app file itself as well as the /Content/Macos/Talend... file.
I'm on Mac OS X 10.6.7 here. Any other suggestions I could try?
regards,
Henrik Nielsen
Community Manager

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi
Please let us know which version of TOS/TIS are you using? What's the error message after you chmod the application and re-unzip the product using 7-zip.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi Shong
I'm using TOS-All-r55913-V4.2.0M4 on Mac OS X 10.6.7 with Java 1.6.0_24-b07-334-10M3326.
The app still won't run from that location I originally unzipped it to. I also tried unzipping it to a different location previously, with the same result. But now, just to make sure, I unzipped it to a third location and tried launching it from there, and this time it works! Very strange. Problem is solved for now, but for reasons unknown Smiley Happy
Now I'm just having problems getting past the 'enter your email'-screen, but that's a different problem entirely I suppose.
regards
Henrik
Community Manager

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi Henrik
V4.2.0M4 is a testing version, I suggest you to download and use the stable version 4.1.2. Anyway, you get it works now!Smiley Wink, please report a new topic with your new question.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi again
I have no idea how I resolved it - it has no stopped working again Smiley Happy When digging a bit deeper, the issue appears to be differing versions of plugin libraries. The error message I get from the app is:
dlopen(../../../plugins/org.eclipse.equinox.launcher.carbon.macosx_1.0.200.v20090520-1835, 2): image not found
When looking in the plugins folder, there is a folder with a name like that, but the version is different:
org.eclipse.equinox.launcher.carbon.macosx_1.1.0.v20100503
So how I had it working is a complete mystery to me; I'll try the stable version and see if that works better for me. Just thought I'd give this piece of "debugging" info if anybody else should enconter this issue.
br
Henrik Nielsen
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

You need to open a terminal and cd into the app dir like this
cd /Applications/JETL_Express-All-r67267-V4.2.3/JETL_Express-macosx-carbon.app/Contents/MacOS
Your path may vary...
The vi - or somehow edit the JETL_Express-macosx-carbon.ini file
The second and fourth lines of this file contain the paths to the important stuff - here's my edited section:

../../../plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.carbon.macosx_1.1.0.v20100503

again - your paths may vary. You need to use a second terminal to see what's actually there.
Talend - your QA process needs to include a system that this hasn't been previously installed on. Smiley Happy
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

Sorry my prior message was a little more cryptic than it should be.
Here's my whole .ini file:

-startup
../../../plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.carbon.macosx_1.1.0.v20100503
--launcher.XXMaxPermSize
256m
-vmargs
-Xms40m
-Xmx256m
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.instance.area.default=../../../workspace
The only lines that you need to edit are 2 and 4.
Assuming you know your way around a terminal and *nix command lines, use a second terminal to list the contents of "../../plugins/" and edit the .ini file appropriately to reflect the installed .jar file - line 2, and the correcto eclipse directory - line 4. HTH.
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

sorry again - it's the
../../../plugins/
directory
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

I just downloaded TOS_DI-20161026_1219-V6.3.0 and receive error message:
The TOS_DI-macosx-cocoa executable launcher was unable to locate its companion shared library.
when I click on TOS_DI-macosx-cocoa.app
I had your previous open studio version installed and was working correctly.  I tried all the steps above.  I did not have eclipse installed, so installed the most recent version. I've added 
/Users/krw/eclipse/java-neon/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
to the ini file.  Still receive same message.  I did not have another file in that directory to add the 2nd line if the above example.
Please advise.
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

Hi,
Unzip the product using iZip for mac.
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

kwestI just downloaded TOS_DI-20161026_1219-V6.3.0 and receive error message:
The TOS_DI-macosx-cocoa executable launcher was unable to locate its companion shared library.
when I click on TOS_DI-macosx-cocoa.app
I had your previous open studio version installed and was working correctly.  I tried all the steps above.  I did not have eclipse installed, so installed the most recent version. I've added 
/Users/krw/eclipse/java-neon/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
to the ini file.  Still receive same message.  I did not have another file in that directory to add the 2nd line if the above example.
Please advise.
One Star

Re: [resolved] Mac Install : unable to locate its companion shared library

The last post worked for me. Thank you!