One Star

[resolved] Getting error when running the job in Talend open studio 6.2.1

Hi,
I am getting the below error when triggering/running a job. I am using Talend open studio data integration 6.2.1 and I am using windows 10 32 bit OS.
Starting job sample at 16:15 02/09/2016.
java.lang.NoClassDefFoundError: Integer
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
at java.lang.Class.privateGetMethodRecursive(Unknown Source)
at java.lang.Class.getMethod0(Unknown Source)
at java.lang.Class.getMethod(Unknown Source)
at sun.launcher.LauncherHelper.validateMainClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Caused by: java.lang.ClassNotFoundException: Integer
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 7 more
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" 
Job sample ended at 16:15 02/09/2016.
Can someone please help me on this issue.
Thanks in advance,
Kind regards,
Sathish
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Sabrina,
Issue is because of the environmental variable, I changed JAVA_HOME to "C:\Program Files\Java\jre1.8.0_101" and now it is resolved.
Thank you very much for your assistance Smiley Happy
Kind regards,
Sathish
13 REPLIES
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi,
What's the JDK version you are using? Are you using JDK 1.8?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

yes Sabrina, I am using jdk 1.8
Kind regards,
Sathish
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi,
Could you please go to Window > Preferences > Installed JREs, selecting Edit and browsing for the appropriate JRE (jdk1.8.0_XXX in your case) to see if it works?
 You are using java 1.8.0_51 or java 8_9? It seems that there is something wrong with java 1.8.0_9.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Sabrina,
I am having jdk1.8.0_101 and in talend installed JRE's is pointing to - C:\Program Files\Java\jre1.8.0_101\bin.
And along with the above error that I posted earlier I am getting additional error in a pop up, please find below the error
java.lang.Exception: Download jts-1.12.jar failed!
at org.talend.librariesmanager.utils.DownloadModuleRunnable.downLoad(DownloadModuleRunnable.java:117)
at org.talend.librariesmanager.utils.DownloadModuleRunnable.run(DownloadModuleRunnable.java:68)
at org.talend.updates.runtime.model.TalendWebServiceUpdateExtraFeature.install(TalendWebServiceUpdateExtraFeature.java:96)
at org.talend.updates.runtime.engine.InstallNewFeatureJob.installFeature(InstallNewFeatureJob.java:74)
at org.talend.updates.runtime.engine.InstallNewFeatureJob.run(InstallNewFeatureJob.java:65)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Please let me know if any further info required.
Thanks in advance,
Kind regards,
Sathish
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Sabrina,
Thanks much for pointing me to the installed JRE's, I changed the path to "C:\Program Files\Java\jre1.8.0_101" and changed the name to "jre1.8.0_101" and now I am able to run the job. 
But when I close the talend and relaunch and upon checking the installed JRE I am seeing the path and name changed. Please find below the picture for the same with a error saying "Target is not a JDK Root. Java executable was not found" and I am able to run the job.
Will this create any other issue when I deploy the code and run it in server or from the command prompt using a batch script.

Thanks in advance for your support.
Kind regards,
Sathish
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi,
Please take a look at my screenshot.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Sabrina,
When I close and relaunch talend the path is getting reset to "C:\Program Files\Java\jre1.8.0_101\bin" and name to "bin".
Please need your assistance in this and let me know if any further info required.
Thanks in advance for your support.
Kind regards,
Sathish
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Sabrina,
Issue is because of the environmental variable, I changed JAVA_HOME to "C:\Program Files\Java\jre1.8.0_101" and now it is resolved.
Thank you very much for your assistance Smiley Happy
Kind regards,
Sathish
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Team,
I installed Java version 1.8 in my 64bit system. Downloaded Talend application version 6.3.1. When I try to run the Talend application I am getting an error. PLease find attached the error text file.
1487612770492.log.log
Can someone let me know what is the error and how to resolve.
Thanks,
Mahak
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi Mahak,
The attachment you uploaded is not available on forum. Could you please check it? Feel free to paste it directly on forum.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi,
I have Installed Talend Data integration 6.3.1.
OS windows 8,64 bit.
Java Version  

while running the job in talend i am facing an error mentioned below.

Please suggest me solution to resolve this issue.
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi ameysarode,
We don't see any attachment on forum. Could you please paste the error message you are getting into forum directly?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: [resolved] Getting error when running the job in Talend open studio 6.2.1

Hi ameysarode,
Is there any update for your issue?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.