[resolved] Could not create the Java virtual machine

One Star

[resolved] Could not create the Java virtual machine

Tags:
Hello,
On my PC, when I run a job I have the following error:
Could not create the Java virtual machine.
Error occurred DURING initialization of VM
Could not reserve enough space for object heap
So far Talend worked well.
I think the problem occurred after a Windows update to install languages.
In this forum, it is given as a solution, change the arguments as follows:
Xms128m
Xmx512M
but this does not work.
Other actions realized, without success:
- JAVA ReInstallation
- Talend ReInstallation (last version)
thank you

Accepted Solutions
One Star

Re: [resolved] Could not create the Java virtual machine

Thanks shongs,
I have retried to use script command for executed my Talend Job.
I have optimized my argument and now it's Ok.
After verification, I noticed than used arguments are defined in advanced Settings (Tabs Execute). Before I modified the arguments in my preference settings.
Emmanuel

All Replies
Community Manager

Re: [resolved] Could not create the Java virtual machine

Hi
Please have a look at a similar topic:
http://community.talend.com:80/t5/Design-and-Development/resolved-Could-not-create-the-Java-virtual-...
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Could not create the Java virtual machine

Hi,
I have already try solution of this topic (http://community.talend.com:80/t5/Design-and-Development/resolved-Could-not-create-the-Java-virtual-...);
But these solutions don't work:
- decrease arguments value Xms, Xmx.
- Moving the JAVA_HOME/bin entry in the Path variable to the first position (Path=C:\Programmi\Java\jre6\binSmiley Wink
Regards,
Emmanuel
Community Manager

Re: [resolved] Could not create the Java virtual machine

Hi
Open the CMD windows and execute the command as showed in my screenshot to see the max value of Xmx parameter on your computer.
As showed, the max value of Xmx parameter is 1444M on my machine.
You must set the value less than the max value!
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Could not create the Java virtual machine

Thanks shongs,
I have retried to use script command for executed my Talend Job.
I have optimized my argument and now it's Ok.
After verification, I noticed than used arguments are defined in advanced Settings (Tabs Execute). Before I modified the arguments in my preference settings.
Emmanuel
Community Manager

Re: [resolved] Could not create the Java virtual machine

Hi
I have retried to use script command for executed my Talend Job.
I have optimized my argument and now it's Ok.

Good news! Thanks for your feedback!
After verification, I noticed than used arguments are defined in advanced Settings (Tabs Execute). Before I modified the arguments in my preference settings.

To set the jvm parameters in advacned settings is only valid for the current job, however, the modification of jvm arguments in preference will be valid for all jobs.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Could not create the Java virtual machine

Most of the time you can fix this problem by uninstalling the Java runtime and then reinstalling it all over again.

You can also try increasing the amount of system memory allocated to the Java virtual machine by setting an environment variable.

Open the Control Panel
Go to System
Go to Advanced Systems Properties
Then Environment Variables
In System Variables, click Add
New Variable Name: _JAVA_OPTIONS
New Variable Value: -Xmx512M
Click OK

That’s it, your Java program should now be able to execute properly.
For those interested, Java -Xmx/s is the configuration parameter that control the amount of memory Java uses.

Xmx sets the maximum heap memory size
Xms sets the minimum heap memory size