One Star

[resolved] Changing server URL for Talend Admin Center on Amazon EC2

We have installed TAC 4.2.3 on a new AMAZON EC2 server. During the installation, the URL was an Amazon Elastic IP address. After the system was up and running, we changed the Elastic IP on this new server to a different URL. Now when I open TAC Configuration page, the Web Console URL points to the original URL and gives me an error. How can I change it to the new URL?
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Changing server URL for Talend Admin Center on Amazon EC2

JasperSoft (Kris Collins) helped us figure this out. Apparently the web console setting is cached in Tomcat. Here is what Kris found:
I?m finding that there isn?t really a configuration for this. After some fiddling, I realized that I can make this IP change by how I call it in the browser. I?m thinking it may be cached somehow. This is what I did:
1.) I was using http://localhost:8080/tispro/ for my local install, so of course my setting here was: http://localhost:8080/tispro/h2console
2.) Stopped tomcat, cleared my browser cache, and restarted tomcat.
3.) Instead of going to http://localhost:8080/tispro/, I went to my local IP http://10.0.0.150/tispro/ and logged in.
4.) My setting was now correct based on my ip: http://10.0.0.150:8080/tispro/h2console
That was it. I went back and forth a couple of times to make sure. I would imagine if I force change my private IP to something else it would also work.
1 REPLY
One Star

Re: [resolved] Changing server URL for Talend Admin Center on Amazon EC2

JasperSoft (Kris Collins) helped us figure this out. Apparently the web console setting is cached in Tomcat. Here is what Kris found:
I?m finding that there isn?t really a configuration for this. After some fiddling, I realized that I can make this IP change by how I call it in the browser. I?m thinking it may be cached somehow. This is what I did:
1.) I was using http://localhost:8080/tispro/ for my local install, so of course my setting here was: http://localhost:8080/tispro/h2console
2.) Stopped tomcat, cleared my browser cache, and restarted tomcat.
3.) Instead of going to http://localhost:8080/tispro/, I went to my local IP http://10.0.0.150/tispro/ and logged in.
4.) My setting was now correct based on my ip: http://10.0.0.150:8080/tispro/h2console
That was it. I went back and forth a couple of times to make sure. I would imagine if I force change my private IP to something else it would also work.