One Star

[resolved] Can I download Eclipse target platform file of TOS-DI?

Nice, leaving the Post for the first time.
Currently looking at the source code of Talend Open Studio 5.5.1.

tdi-studio-se / release / 5.5.1(https://github.com/Talend/tcommon-studio-se)
tcommon-studio-se / release / 5.5.1(https://github.com/Talend/tdi-studio-se)
It explores how to behave in Talend Open Studio to modify and distribute the source code of the plugin.
The error that occurs is related to the plug-ins and see when you want to deploy the plug-org.talend.rcp.

Want to resolve this in a way was sought,
You want to fit in Talend Studio development environment for Eclipse target platform first.

Can I get a Talend Studio Eclipse target platform file (* .target)?
or
Talend Studio Developer Guide?

eclipse_error.log.log
3 REPLIES
Employee

Re: [resolved] Can I download Eclipse target platform file of TOS-DI?

Actually the best thing you can do it to use the TOS-DI build as a target platform.
Got to Eclipse->Windows->Preferences/Plug-in development/Target platform.
Create a new empty target platform using the "add..." button and use the "Directory" content type to add the root of the Studio as a target platform. 
This should get you going.
SeB.
One Star

Re: [resolved] Can I download Eclipse target platform file of TOS-DI?

? My Development Environment

Operation System
Ubuntu 14.04 LTS

Java Version: JDK 7
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

Eclipse
Eclipse for RCP and RAP Developers
Version: Luna Service Release 1 (4.4.1)
Build id: 20140925-1800

Target Platform
Use TOS-DI TOS_DI-r118616-V5.5.1 set.

? Source Development Method

My purpose: Analysis TOS DI v5.5.1 operation.

git clone tcommon-studio-se : https://github.com/Talend/tcommon-studio-se
git clone tdi-studio-se: https://github.com/Talend/tdi-studio-se
branch checkout: release/5.5.1(tcommon-studio-se & tdi-studio-se)
copy files into talend-studio directory
$ mkdir talend-studio
$ cp -a tcommon-studio-se/* talend-studio/
$ cp -a tdi-studio-se/* talend-studio/
$ cd talend-studio
$ mvn clean install(then org.talend.utils build)

Eclipse(Luna Service Release 1 (4.4.1)) launch
Target platform set up and
6.1. Installation folder: TOS-DI TOS_DI-r118616-V5.5.1 directory
API Baselines reset
‘Plug-in Development -> Import Plug-ins and Fragment’

Import From: Directory(./talend-studio)
Plug-ins and Fragments to Import: ‘Select From all plug-ins and fragments fount at the specified location’
Import As: Projects with source Folders
8.1. ‘add: org.talend.core’ and ‘Required Plug-ins’
8.2. ‘add: org.talend.rcp’ and ‘Required Plug-ins’
8.3. ‘add: org.talend.rcp.branding.tos’ and ‘Required Plug-ins’
8.4.

Importing plug-ins and Project clean and build.
Occur similar error
The project cannot be built until its prerequisite org.talend.common.ui.runtime is built. Cleaning and building all projects is recommended    org.talend.common.ui.runtime.nl        Unknown    Java Problem

How can I solve this problem?

attachment file: Errors
error_100_of_12873.xls.zip.zip
One Star

Re: [resolved] Can I download Eclipse target platform file of TOS-DI?

Ooops. I'm sorry.
My mistake.
Don't click 'Required Plug-ins' when 'Import plug-ins and Fragments'.
1. Set target platform.
2. import plug-in project(seperate).