Five Stars

Where to get the Oracle sdoutil and sdoapi.jar

Hi, I'm using Open Studio Data integration 6.3 and have added a Oracle db connection. It checks fine. But when I want to use it in a job I get an error stating I need 2 additional jar files: sdoapi and sdoutil.jar.

 

I'v searched in the Oracle server, on the Oracle website and googled around. But I can't find the 2 files. Can someone tell me where to get them? Thank you.

6 REPLIES
Moderator

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hello,

 It looks like sdoapi and sdoutil.jar are used for Geometry in oracle. Do you want to write geographical data to an SDO_GEOMETRY column in Oracle? What's JDK version you are using?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hi,

 

It is strange why TOS wants the jars because I want to extract plain data from a Oracle db and not geographical info. I'm using jdk1.8.0_112.

 

But I have found the jar on https://mvnrepository.com/artifact/oracle/sdoapi/11.2.0. Talend accepts the 2 jars and now I have a working connection.

Moderator

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hello,

We have made a testing on talend open studio V 6.3 and it doesn't want the jars. What's oracle version you are trying to connect?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hi, I had it with 2 db connections. One Oracle 10 and one Oracle 11. As soon as I dragged the db from the metadata to the job field it gave the error.

Moderator

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hello,

Does this issue also repro on V 6.5.1?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Where to get the Oracle sdoutil and sdoapi.jar

Hi, I've installed V6.3 and V6.5.1 locally for this test.

Version 6.5.1 works nicely. The local 6.3 also gives the error. I've added a printscreen. But most important is that it functions. I can't upgrade to 6.5 just yet because if I create jobs in 6.5 there's a risk it won't run on 6.3 environments. I share my jobs with other organisations in the same field (local government) who also run 6.3. I'll ask if they also have the jar problem.