Unable to install - service: command not found

One Star

Unable to install - service: command not found

Hello All,

I am working with a user who is seeing the below error when trying to install ETL 5.2.2:
/bin/sh: service: command not found
below is the contents of the error log:
Log started 01/06/2014 at 16:45:43
Preferred installation mode : osx
Trying to init installer in mode osx
Error loading image leftImage. Incorrect format?
Error loading image splashImage. Incorrect format?
Mode osx successfully initialized
Executing service jaspersoft-jac stop
Script exit code: 127
Script output:

Script stderr:
/bin/sh: service: command not found
Error running service jaspersoft-jac stop : /bin/sh: service: command not found
Executing service jaspersoft-cmdline stop
Script exit code: 127
Script output:

Script stderr:
/bin/sh: service: command not found
Error running service jaspersoft-cmdline stop : /bin/sh: service: command not found
Does this have anything to do with the path not being set to absolute path?
Thanks,
Doug
Moderator

Re: Unable to install - service: command not found

Hi,
Did your use jasper OEM? Did you use MAC OS? Is it working when you get in the installation directory?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install - service: command not found

Hello,

The user is using jasper OEM. Here are some comments from the user: " I work on Mac OS X 10.8.4. I couldn't find /sbin/service script install. Based on what I found on http://forums.cnet.com/7726-6132_102-2383069.html, /sbin/service is vulnerable in MAC that's why the service script is not part of Mac"
Thanks,
Doug
Moderator

Re: Unable to install - service: command not found

Hi,
I suspect the path can't be recognized by system.
Is it working when you get into the installation directory?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install - service: command not found

Which path should be changed? Also, can you please clarify when you ask "Is it working when you get into the installation directory?"
Moderator

Re: Unable to install - service: command not found

Hi,
Did the user use subscription version product? If so, he can open a ticket on Talend Support Portal so that we can give a remote assistance.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads