Unable to install on Mac OS X El Capitan

One Star

Unable to install on Mac OS X El Capitan

I have downloaded Open Studio Data Integration.  I was then prompted to install Java, which I did.  I am double-clicking "TOS_DI-macosx-cocoa.app" to try and start Open Studio. On attempting to start Open Studio I get a dialog stating "An Error has occurred.  See the log file.  null".  Top part of log file show below.  Can anyone help?  Many thanks.
!SESSION 2016-01-19 09:31:12.334 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
!ENTRY org.eclipse.osgi 4 0 2016-01-19 09:31:12.834
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:171)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.loadConfigurators(HookRegistry.java:185)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.initialize(HookRegistry.java:106)
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:73)
at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:295)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:231)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
!ENTRY org.eclipse.equinox.ds 4 0 2016-01-19 09:31:13.043
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.ds
  Unresolved requirement: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.compare.win32 4 0 2016-01-19 09:31:15.547
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.talend.commons.ui 4 0 2016-01-19 09:31:15.594
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.commons.ui
  Unresolved requirement: Require-Bundle: org.talend.utils
    -> Bundle-SymbolicName: org.talend.utils; bundle-version="6.1.1.20151214_1327"
       org.talend.utils
         Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
           -> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.2.0.RELEASE"
              org.talend.daikon
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.talend.component.core 4 0 2016-01-19 09:31:15.598
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.component.core
  Unresolved requirement: Require-Bundle: org.talend.core
    -> Bundle-SymbolicName: org.talend.core; bundle-version="6.1.1.20151214_1327"; singleton:="true"
       org.talend.core
         Unresolved requirement: Require-Bundle: org.talend.metadata.managment
           -> Bundle-SymbolicName: org.talend.metadata.managment; bundle-version="6.1.1.20151214_1327"; singleton:="true"
              org.talend.metadata.managment
                Unresolved requirement: Require-Bundle: org.talend.core.runtime
                  -> Bundle-SymbolicName: org.talend.core.runtime; bundle-version="6.1.1.20151214_1327"; singleton:="true"
                     org.talend.core.runtime
                       Unresolved requirement: Require-Bundle: org.talend.model
                         -> Bundle-SymbolicName: org.talend.model; bundle-version="6.1.1.20151214_1327"; singleton:="true"
                            org.talend.model
                              Unresolved requirement: Require-Bundle: org.talend.utils
                                -> Bundle-SymbolicName: org.talend.utils; bundle-version="6.1.1.20151214_1327"
                                   org.talend.utils
                                     Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
                                       -> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.2.0.RELEASE"
                                          org.talend.daikon
                                            Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.talend.component.ui.wizard 4 0 2016-01-19 09:31:15.600
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.component.ui.wizard
  Unresolved requirement: Require-Bundle: org.talend.model; visibility:="reexport"
    -> Bundle-SymbolicName: org.talend.model; bundle-version="6.1.1.20151214_1327"; singleton:="true"
       org.talend.model
         Unresolved requirement: Require-Bundle: org.talend.utils
           -> Bundle-SymbolicName: org.talend.utils; bundle-version="6.1.1.20151214_1327"
              org.talend.utils
                Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
                  -> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.2.0.RELEASE"
                     org.talend.daikon
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.talend.componentdesigner 4 0 2016-01-19 09:31:15.603
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.componentdesigner
  Unresolved requirement: Require-Bundle: org.talend.model
    -> Bundle-SymbolicName: org.talend.model; bundle-version="6.1.1.20151214_1327"; singleton:="true"
       org.talend.model
         Unresolved requirement: Require-Bundle: org.talend.utils
           -> Bundle-SymbolicName: org.talend.utils; bundle-version="6.1.1.20151214_1327"
              org.talend.utils
                Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
                  -> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.2.0.RELEASE"
                     org.talend.daikon
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$Ev
Moderator

Re: Unable to install on Mac OS X El Capitan

Hi,
Since version 6.0.0, Java 8 is recommended and Java 7 is a minimum. Make sure you installed the appropriate Java version.
Please refer to:TalendHelpCenter:Compatible Platforms and Java environments
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install on Mac OS X El Capitan

Thanks xdshi.  I simply followed the download links as seen during the install/start-up process.  This took me here: .
I'll try installing a later version.
Thanks for your help.
Moderator

Re: Unable to install on Mac OS X El Capitan

Hi,
Let us know if it is OK with you after installing a later java version(java 8)
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install on Mac OS X El Capitan

I have the exact same issue, and have installed the latest java version ( 1.8 ) and made appropriate changes to my .bash_profile such that in a shell I see the following:
ken.cluff@ken-mbp-macos ~ $ env | grep JAVA
JAVA_HOME=/sbin/java1.8
ken.cluff@ken-mbp-macos ~ $ ll /sbin | grep java
lrwxr-xr-x   1 root  wheel    65B Jan 21 10:58 java1.8@ -> /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/
ken.cluff@ken-mbp-macos ~ $ env | grep PATH
PATH=/Users/ken.cluff/.rbenv/shims:/sbin/java1.8/bin:/Users/ken.cluff/.rbenv/bin:/Library/PostgreSQL/9.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/MacGPG2/bin
ken.cluff@ken-mbp-macos ~ $ which java
/sbin/java1.8/bin/java
ken.cluff@ken-mbp-macos ~ $ java -version
java version "1.8.0_71"
Java(TM) SE Runtime Environment (build 1.8.0_71-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.71-b15, mixed mode)
ken.cluff@ken-mbp-macos ~ $ 

But I still can't even INSTALL Talend because the installer ( invoked by double clicking Talend-Tools-Installer-20151214_1327-V6.1.1-osx-installer.app in the finder ) errors out sayong it could not find a valid java on this machine. 

It's as if it's seeing a different environment than I'm seeing in the shell. Do I need ot do the install and the start of talend from inside the shell? 
Moderator

Re: Unable to install on Mac OS X El Capitan

Hi ken,
Did you configure JDK in Talend studio?
Please refer to kb article about:TalendHelpCenter:Requiring a JDK installation to build jobs starting from version 6.0?
Are you using Talend Installer to install Talend subscription 6.1? Have you already checked document about:TalendHelpCenter:Talend Installer specific prerequisites
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install on Mac OS X El Capitan

Hi Culture / Ken, I had the same issue as described by Culture.
After installing the package Java for OS X 2015-001 provided by Apple:
https://support.apple.com/kb/DL1572?locale=en_US
And the Java JDK 8 provided by Oracle:
http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
everything seems to work for me. Maybe it could also be a solution for you. 
Good luck!
Hans
One Star

Re: Unable to install on Mac OS X El Capitan

Hi Culture / Ken, I had the same issue as described by Culture.
After installing the package Java for OS X 2015-001 provided by Apple:

And the Java JDK 8 provided by Oracle:

everything seems to work for me. Maybe it could also be a solution for you. 
Good luck!
Hans

Yes that worked!  I was getting the same 'Null' error.  The PDF documentation indicates that JRE needs to be installed, which I did, but it wasn't until I followed your steps and did the jdk8 download did it work.  Thanks!