Unable to install Additional Packages

Five Stars

Unable to install Additional Packages

 

 Hi,Capture2.PNG

 

 

 

when i try to download the additional installation package from help menu,it stops with 0% and shows this error.

Thanks,

raj

 

Moderator

Re: Unable to install Additional Packages

Hello,

 Can you please clarify in which Talend version/edition you are? Is your network OK with you? Are you behind proxy or outof proxy?

More information will be helpful for us to address your issue.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Unable to install Additional Packages

Hi,

iam using talend

Version: 7.0.1.20180411_1414

Network is fine

out of proxy

Moderator

Re: Unable to install Additional Packages

Hello,

Is there any more error information in your log?

We cannot repro this issue on window 10, v 7.0.1 from our side. What's OS are you using? Does this issue repro on other build version, v 6.5.1?

Could you please try to pause your Anti Virus to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Unable to install Additional Packages

Hi

 

I am facing the same issue. Please advice how can I import additional packages in Talend Studio.

 

I have downloaded TOS_DI-20180411_1414-V7.0.1 for Data integration.

 

Thanks & Regards,

Care Career

 

Five Stars

Re: Unable to install Additional Packages

Hi care career,

once you installed talend go to " help" in the top of the menus and select "install additional packages",

there after loading you will see third party and optional packages click third party and install all the jar files.

 

Thanks,

Rajkumar

 

Moderator

Re: Unable to install Additional Packages

Hello,

Is your network OK with you? Are you behind proxy? Do your proxy server have any restrictions to HTTP/HTTPS? Is it open to all websites?

Best regards

Sabrina



 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to install Additional Packages

I'm also having problems installing packages (TOS for DI 7.0.1.20180411_1414) on Windows 7 64 bit , but what I have found is that each time I attempt to install them, it tells me that there are fewer packages now to be installed. (e.g. for the "Optional third party libraries", it was showing around 1860, then 1857, then 1852, 1840, 1837, that kind of thing.

Now whilst this is potentially good news (in that it is installing), you can see  that installing 1800+ libraries, 3 or 4 at a time, is going to take me a lot of invocations of the "Install Additional Packages" dialog.

I suggest that this behaviour would indicate some of the following:

(1) Possibly it is actually managing to install a few each time (but I know of no way to verify this)

(2) Possibly it thinks it's managing to install each time, but is failing and yet the count is still going down because of a bug

(3) If it is actually managing to install, then perhaps it is poor network quality that causes it to fail, although that seems unlikely

(4) If it is actually managing to install, then perhaps talend has some timeouts set too low (so network quality could be an issue?), and they are being exceeded

(5) If it is actually managing to install, then perhaps talend is attempting installation in the wrong order and there are some dependencies which are gradually being rectified with each attempt at installation

 

My network does have a proxy server, and I am running AV software. As it is a corporate network and locked down I have no control over any of this, but given that it is apparently "trickling through" with each attempt, I'd suggest that the problem is not with it being behind a proxy (which would presumably stop it dead if it were the issue).


Fortunately the "required" packages (apparently) installed for me over about 3 or 4 iterations. As the failing ones are "optional", and there are still 1837 to go, I shall leave them uninstalled until such time as they are definitely required at which point I'm assuming TOS will alert me once more.

 

So... whilst I would welcome any suggestions on what the issue is here, I think it useful to note that the installation of the additional packages might be achievable for some people who have this problem, simply by repeatedly choosing the "install additional packages" option on the Help menu (and having a lot of patience.. mine's actually now down to below 1700 woo hoo!!)