One Star

Talend refuse to start

Hi,
I would like to install TALEND 4.2 on my laptop but after the installation it don't want to start.
I've try other versions without succes...
I've a Java environnement (netbeans is running well), under windows 7 x64 familly edition.

28 REPLIES
Community Manager

Re: Talend refuse to start

Hi
Please upload the log message which locates on /workspace/.metadata/
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Talend refuse to start

Hi,
There is no /.metadata
The .exe just refuse to execute himself, without any logs or pop up message...
I click and ... nothing happend...
Community Manager

Re: Talend refuse to start

Hi
There should be a permission problem, try to right click on it and run it with administrator role.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Talend refuse to start

Nothing more happend...
When I start the TalendOpenStudio-win-x86_64.exe (the one with the eclipse icon), an error pop up to tell: "Failed to load the JNI shared library D:\Java\Jre6\bin\client\jvm.dll "
But this file exist.
I realy think it's a problem of x86 - x64...
One Star

Re: Talend refuse to start

Encountered the exact same problem. Using Windows 7 Ultimate 64bit
Uninstalled my 64bit jdk and installed 32 bit jdk works perfectly now
The versions have to be the same
Hope this helps
One Star

Re: Talend refuse to start

I had the same issue running TOS 5.0. Here is the solution:
Talend installation comes with both 32bit and 64bit applications. By default, in windows start menu, 32bit application is shown. When you try to open the application using windows start button -> programs -> TOS, it tries to open 32bit application.
Instead, go to the install directory and run: TOS_DI-win-x86_64.exe.
It worked fine for me. I hope this helps.
Adiss
One Star

Re: Talend refuse to start

Had the same problem as above and Adiss's post worked for me as well ... running the x86_64.exe from the installation directory.
OS is win7 professional 64bit.
Thanks for posting a solution.
One Star

Re: Talend refuse to start

Try to start as admin.
One Star

Re: Talend refuse to start

Do you have configure JAVA_HOME and JRE_HOME ?
Try to force a specific jvm at startup with this option in the 32 bit or 64 bit .ini file :

-vm
c:\java\jdk1.6.0.25\bin\java
(two different line)
One Star

Re: Talend refuse to start

I had the same issue running TOS 5.0. Here is the solution:
Talend installation comes with both 32bit and 64bit applications. By default, in windows start menu, 32bit application is shown. When you try to open the application using windows start button -> programs -> TOS, it tries to open 32bit application.
Instead, go to the install directory and run: TOS_DI-win-x86_64.exe.
It worked fine for me. I hope this helps.
Adiss

Worked for me ass well this way !! THX
One Star

Re: Talend refuse to start

thx a lot....u saved my time...



I had the same issue running TOS 5.0. Here is the solution
Talend installation comes with both 32bit and 64bit applications. By default, in windows start menu, 32bit application is shown. When you try to open the application using windows start button -> programs -> TOS, it tries to open 32bit application.
Instead, go to the install directory and run: TOS_DI-win-x86_64.exe.
It worked fine for me. I hope this helps.
Adiss
One Star

Re: Talend refuse to start

Hello,
I have the same message failed to load the jni shared library "C:\program files\java\jre7\bin\client\jvm.dll"
when i want to launch talend open studio
thank you for help,
flore
Moderator

Re: Talend refuse to start

Hi flore,
What's your OS? Win7 64 bit? Is this solution not working for you?
I had the same issue running TOS 5.0. Here is the solution
Talend installation comes with both 32bit and 64bit applications. By default, in windows start menu, 32bit application is shown. When you try to open the application using windows start button -> programs -> TOS, it tries to open 32bit application.
Instead, go to the install directory and run: TOS_DI-win-x86_64.exe.
It worked fine for me. I hope this helps.

If not, please follows the steps as below to restore the items.
1. Back up the workspace.
2. Delete the workspace and restart the studio
3. Import all items from the backup of workspace done in step1.
Let me know if it is OK with you.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

Hi Sabrina,
My OS is Win 8 64bit
One Star

Re: Talend refuse to start

I will try this way
Instead, go to the install directory and run: TOS_DI-win-x86_64.exe.
but i have the same message
Thanks for your return
Moderator

Re: Talend refuse to start

Hi,
Did you run your studio before successfully?
Try this solution
If not, please follows the steps as below to restore the items.
1. Back up the workspace.
2. Delete the workspace and restart the studio
3. Import all items from the backup of workspace done in step1.

and tell me the result.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

what is the studio ?
Moderator

Re: Talend refuse to start

Hi,
I have the same message failed to load the jni shared library "C:\program files\java\jre7\bin\client\jvm.dll"
when i want to launch talend open studio

Did your talend open studio run successfully before? Or it is failed at the first time?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

It is failed at first time
Moderator

Re: Talend refuse to start

Hi,
If your studio is failed at first time, you should make sure that:
1. Install corresponding JDK, install 64bit JDK on 64bit system.
2. Type java -version in Commandline to see if it is command. If not, you need to set your JRE correctly.
3. Set Java environment variables correctly.
4. There is no extra space and illegal character in your installation path.
For more info please refer to TalendHelpCenter:Installation+requirements
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

Hi,
I have been running Talend 5.5.1 Data Integration on a 64bit system fine but yesterday things went south, I am now getting the dreaded  "failed to load the jni shared library "C:\java\jre7\bin\client\jvm.dll".  I tried uninstalling and reinstalling, no change.  My Java versions:

java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java Hotspot(TM) 64-bit server VN (build 24.65-b04, mixed mode)

My environment variables:
CLASSPATH  C:\Java
JAVA_HOME  C:\Java\jdk 1.7.0_67

I have downloaded JSL, didn't seem to make any difference.   I also downloaded 32-bit jdk 1.7.0_67 and pointed JAVA_HOME at it (CSmiley Very Happy\Java\32bit\jdk 1.7.0_67) but that didn't sort it out.    
Can you offer any help?
Thanks, Mark
Moderator

Re: Talend refuse to start

Hi crit87,

Could you please re-install your talend studio to see if everything is Ok with you?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

Hi All,
 
I am getting error message when i launch 64 bit Talend exe , i have installed java 1.7  64 bit and my OS is running on 64 bit but still not able to understand the root cause, license should not be an issue and also no other java version is running , all paths are set , any response is appreciated 
 
!SESSION 2016-03-06 21:39:33.237 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_80
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.equinox.app 0 0 2016-03-06 21:39:42.942
!MESSAGE Product org.talend.rcp.branding.generic.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2016-03-06 21:39:43.943
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-03-06 21:39:43.943
!!SUBENTRY 2 org.talend.metadata.managment.ui 2 0 2016-03-06 21:39:44.207
!MESSAGE Missing required bundle org.talend.datatools.xml_0.0.0.
!SUBENTRY 2 org.talend.metadata.managment.ui 2 0 2016-03-06 21:39:44.207
!MESSAGE Missing required bundle org.talend.core.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-03-06 21:39:44.207
!MESSAGE Bundle org.talend.utils_5.4.2.r117442 was not resolved.
!SUBENTRY 2 org.talend.utils 2 0 2016-03-06 21:39:44.207
!MESSAGE Missing required bundle org.talend.libraries.apache_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-03-06 21:39:44.207
!MESSAGE Bundle org.talend.sqlbuilder.nl_5.4.2.r117442 was not resolved.
!SUBENTRY 2 org.talend.sqlbuilder.nl 2 0 2016-03-06 21:39:44.207
!MESSAGE Missing host org.talend.sqlbuilder_0.0.0.

!ENTRY org.eclipse.osgi 4 0 2016-03-06 21:39:44.208
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
Moderator

Re: Talend refuse to start

Hi Gaurav_comp_2,
Could you please indicate the build version you are using? Talend open source or Talend Subscription Solution?
Have you checked the document about:TalendHelpCenter:Compatible+Platforms+and+Java+environments to see if you are on a compatible platform?
Have you tried JDK 1.8 to see if it works?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend refuse to start

Hi Gaurav_comp_2,
Could you please indicate the build version you are using? Talend open source or Talend Subscription Solution?
Have you checked the document about:TalendHelpCenter:Compatible+Platforms+and+Java+environments to see if you are on a compatible platform?
Have you tried JDK 1.8 to see if it works?
Best regards
Sabrina

Thanks for the reply, now the tool seems to be working the zip file that i had some issue so as suggested by Balzas i re extracted the file with short path and that worked!!
Thanks
Gaurav
One Star

Re: Talend refuse to start

HI,
i am unable to launch my talend BD studio. it is failing with below error.  i have windows 7 64 bit OS.
from error llog i coould see ":Command-line arguments:  -os win32 -ws win32 -arch x86_64:

!SESSION 2016-03-14 06:11:36.467 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_60-ea
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64
!ENTRY org.eclipse.jdt.launching.macosx 4 0 2016-03-14 06:11:38.117
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2016-03-14 06:11:38.121
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
One Star

Re: Talend refuse to start

Hello,
I have TOS DI 6.1.1 and Java 8 on Windows 7 setup. However, when I execute commandline.bat or Talend-Studio-win-*.exe, I keep getting the error "Failed to load the Share JNI library ....jvm.dll
What should I do to fix this.
Moderator

Re: Talend refuse to start

Hi,
Is your Window 7 32 bit or 64 bit? How about your JDK 8? Please keep your OS consistent with your JDK(64 bit OS, 64 bit JDK)
TOS_DI-win32-x86.exe is for 32 bit and TOS_DI-win-x86_64.exe is for 64 bit.
Best regards
Sabrina 
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.