One Star

Talend Won't Start

The logo pops up and then disappears....
There seems to be a recurring theme in the last half of my log file.....
The whole log file is HUGE.... But here are some of the "tops" of the various !ENTRY sections.
I read something about "refreshing the workspace" but cannot find any documentation on how to do that....
********************** HELP ********************

================= LOG EXCERPTS BELOW ===========================
Command-line arguments: -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.core.resources 2 10035 2008-05-06 16:36:53.998
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!ENTRY org.eclipse.osgi 4 0 2008-05-06 16:36:54.045
!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (51).
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1018)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
:
:
:
:
Command-line arguments: -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.core.resources 2 10035 2008-05-06 16:36:53.998
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!ENTRY org.eclipse.osgi 4 0 2008-05-06 16:36:54.045
!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (51).
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1018)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
:
:
:
:

!ENTRY org.eclipse.core.runtime 4 2 2008-05-06 16:36:54.060
!MESSAGE Problems encountered starting up plug-in: "org.osgi.framework.BundleException: The activator org.epic.perleditor.PerlEditorPlugin for bundle org.epic.perleditor is invalid".
!STACK 0
org.osgi.framework.BundleException: The activator org.epic.perleditor.PerlEditorPlugin for bundle org.epic.perleditor is invalid
at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:141)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:970)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:877)
at org.eclipse.core.internal.plugins.PluginDescriptor.doPluginActivation(PluginDescriptor.java:360)
at org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin(PluginDescriptor.java:340)
at org.eclipse.core.runtime.Platform.getPlugin(Platform.java:736)
at org.eclipse.core.internal.preferences.legacy.InitLegacyPreferences.init(InitLegacyPreferences.java:43)

:
:
:

!ENTRY org.eclipse.core.runtime 4 2 2008-05-06 16:36:54.060
!MESSAGE Problems encountered starting up plug-in: "org.osgi.framework.BundleException: The activator org.epic.perleditor.PerlEditorPlugin for bundle org.epic.perleditor is invalid".
!STACK 0
org.osgi.framework.BundleException: The activator org.epic.perleditor.PerlEditorPlugin for bundle org.epic.perleditor is invalid
at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:141)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:970)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:877)
at org.eclipse.core.internal.plugins.PluginDescriptor.doPluginActivation(PluginDescriptor.java:360)
at org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin(PluginDescriptor.java:340)
at org.eclipse.core.runtime.Platform.getPlugin(Platform.java:736)
:
:
:
!ENTRY org.eclipse.osgi 4 0 2008-05-06 16:36:54.638
!MESSAGE Application error
!STACK 1
java.lang.NoClassDefFoundError: org/eclipse/core/resources/IProject
at org.talend.repository.ui.login.LoginComposite.populateProjectList(Unknown Source)
at org.talend.repository.ui.login.LoginComposite.unpopulateRemoteLoginElements(Unknown Source)
at org.talend.repository.ui.login.LoginComposite.fillContents(Unknown Source)
at org.talend.repository.ui.login.LoginComposite.<init>(Unknown Source)
at org.talend.repository.ui.login.LoginDialog.createDialogArea(Unknown Source)
at org.eclipse.jface.dialogs.TitleAreaDialog.createContents(TitleAreaDialog.java:147)
at org.eclipse.jface.window.Window.create(Window.java:426)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1081)
at org.eclipse.jface.window.Window.open(Window.java:785)
at org.talend.rcp.intro.Application.logUserOnProject(Unknown Sour
:
:
:
... 97 more
!ENTRY org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE Bundle update@plugins/org.eclipse.platform.source.win32.win32.x86_3.3.0.v20070612-_19UEkLEzwsdF9jSqQ-G/ was not resolved.
!SUBENTRY 2 org.eclipse.platform.source.win32.win32.x86 2 0 2008-05-06 16:36:54.717
!MESSAGE Missing host org.eclipse.platform.source_3.3.0.v20070612-_19UEkLEzwsdF9jSqQ-G.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE Bundle update@plugins/org.eclipse.rcp.source.macosx.carbon.ppc_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG/ was not resolved.
!SUBENTRY 2 org.eclipse.rcp.source.macosx.carbon.ppc 2 0 2008-05-06 16:36:54.717
!MESSAGE Missing host org.eclipse.rcp.source_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE Bundle update@plugins/org.eclipse.platform.source.linux.gtk.ppc_3.3.0.v20070612-_19UEkLEzwsdF9jSqQ-G/ was not resolved.
!SUBENTRY 2 org.eclipse.platform.source.linux.gtk.ppc 2 0 2008-05-06 16:36:54.717
!MESSAGE Missing host org.eclipse.platform.source_3.3.0.v20070612-_19UEkLEzwsdF9jSqQ-G.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE Bundle update@plugins/org.eclipse.rcp.source.linux.gtk.x86_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG/ was not resolved.
!SUBENTRY 2 org.eclipse.rcp.source.linux.gtk.x86 2 0 2008-05-06 16:36:54.717
!MESSAGE Missing host org.eclipse.rcp.source_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.717
!MESSAGE Bundle update@plugins/org.eclipse.rcp.source.win32.wpf.x86_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG/ was not resolved.
:
:
:
!ENTRY org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.linux.ppc_1.0.100.v20070430.jar was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.linux.x86_1.1.0.v20070416.jar was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.linux.x86_64_1.0.100.v20070510.jar was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.macosx_1.0.0.v20060603.jar was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.solaris.sparc_1.0.100.v20070425.jar was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-06 16:36:54.732
!MESSAGE Bundle update@plugins/org.eclipse.emf.ocl_1.1.0.v200706201508.jar was not resolved.
!SUBENTRY 2 org.eclipse.emf.ocl 2
:
:
:
6 REPLIES
Community Manager

Re: Talend Won't Start

Hello
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

Just remove folder
workspace\.metadata\.plugins\org.eclipse.core.resources\.root\.indexes
and restart TOS.
Please let me know if you have fixed the problem.
Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Talend Won't Start

Thanks Shong for your prompt reply!
In researching solutions, I found another post: http://talendforge.org/forum/viewtopic.php?id=2389
which suggested backup of the workspace folder and then delete it and import the project from the backup. That worked for me as well. Next time (if there is one), I'll try your solution - it seems a bit easier.
One Star

Re: Talend Won't Start

Just remove folder
workspace\.metadata\.plugins\org.eclipse.core.resources\.root\.indexes
THis did not work. Just makes things worse.
Employee

Re: Talend Won't Start

Just remove folder
workspace\.metadata\.plugins\org.eclipse.core.resources\.root\.indexes
THis did not work. Just makes things worse.

hi,
If you have any troubles with deleting only indexes, you can do like SMaz said:
I found another post: http://talendforge.org/forum/viewtopic.php?id=2389
which suggested backup of the workspace folder and then delete it and import the project from the backup.

Regards.
Michael
One Star

Re: Talend Won't Start

I did this way..
I renamed .metadata and opened eclipse in the same workspace.
Then closed the workspace.
Copied the contents of newly created .metadata to old renamed .metadata
Started Eclipse.. Everything was fine..
One Star

Re: Talend Won't Start

what if I accidentally deleted parts of My workspace folder?
the default path of tFileDelete is some path in the workspace.
and I think I run it with the default settings, maybe making it even worse by choosing 'delete folder' option.