Four Stars

Talend Studio sometimes does't start: could not resolve some module

Hi.

When I start Talend Studio 6.3.1, randomly I got an error during startup and I have to start it again.

The error frequency is varying: some days is once a day, other days it takes 3 or 4 attemps to run Talend.

These errors are always some kind of Could not resolve module.

 

Below are some examples.

90% are about bonita.

Thanks.

 

eclipse.buildId=unknown
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en
Framework arguments:  -talendReload false -Xmx2048m -Xms 256m
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -talendReload false -Xmx2048m -Xms 256m

!ENTRY org.bonitasoft.studio.actors 4 0 2017-09-12 14:49:29.569
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.bonitasoft.studio.actors [26]
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.connectors; bundle-version="1.0.0"
    -> Bundle-SymbolicName: org.bonitasoft.studio.connectors; bundle-version="7.2.3.201604291519"; singleton:="true"
       org.bonitasoft.studio.connectors [36]
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.engine; bundle-version="1.0.0"
           -> Bundle-SymbolicName: org.bonitasoft.studio.engine; bundle-version="7.2.3.201604291519"; singleton:="true"
              org.bonitasoft.studio.engine [58]
                Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.designer; bundle-version="6.5.0"
                  -> Bundle-SymbolicName: org.bonitasoft.studio.designer; bundle-version="7.2.3.201604291519"; singleton:="true"
                     org.bonitasoft.studio.designer [49]
                       Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
                       Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.groovy.ui; bundle-version="1.0.0"
           -> Bundle-SymbolicName: org.bonitasoft.studio.groovy.ui; bundle-version="7.2.3.201604291519"; singleton:="true"
              org.bonitasoft.studio.groovy.ui [64]
                Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.businessobject; bundle-version="7.1.0"
                  -> Bundle-SymbolicName: org.bonitasoft.studio.businessobject; bundle-version="7.2.3.201604291519"; singleton:="true"
                     org.bonitasoft.studio.businessobject [29]
                       Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
                       Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.3.0"; resolution:="optional"
                       Unresolved requirement: Require-Bundle: org.bonitasoft.studio.engine; bundle-version="1.0.0"
                         -> Bundle-SymbolicName: org.bonitasoft.studio.engine; bundle-version="7.2.3.201604291519"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.engine; bundle-version="1.0.0"
                  -> Bundle-SymbolicName: org.bonitasoft.studio.engine; bundle-version="7.2.3.201604291519"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.data; bundle-version="1.0.0"
           -> Bundle-SymbolicName: org.bonitasoft.studio.data; bundle-version="7.2.3.201604291519"; singleton:="true"
              org.bonitasoft.studio.data [44]
                Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.3.0"; resolution:="optional"
                Unresolved requirement: Require-Bundle: org.bonitasoft.studio.businessobject; bundle-version="6.5.0"
                  -> Bundle-SymbolicName: org.bonitasoft.studio.businessobject; bundle-version="7.2.3.201604291519"; singleton:="true"

 

One more:

eclipse.buildId=unknown
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en
Framework arguments:  -Xmx2048m -Xms 256m
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -Xmx2048m -Xms 256m

This is a continuation of log file C:\Program Files (x86)\Talend-Studio\studio\configuration\1500276798969.bak_0.log
Created Time: 2017-07-17 09:36:03.161

!ENTRY org.eclipse.equinox.launcher.cocoa.macosx 2 0 2017-07-17 09:36:03.163
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx [414]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.s390x 2 0 2017-07-17 09:36:03.165
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.s390x [491]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390x))"


!ENTRY org.bonitasoft.studio.engine 2 0 2017-07-17 09:36:03.168
!MESSAGE Could not resolve module: org.bonitasoft.studio.engine [58]
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="6.4.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.bonitasoft.studio.designer; bundle-version="6.5.0"
    -> Bundle-SymbolicName: org.bonitasoft.studio.designer; bundle-version="7.2.3.201604291519"; singleton:="true"
       org.bonitasoft.studio.designer [49]
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: assertj-core; bundle-version="1.5.0"; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.bonitasoft.studio.tests-utils; bundle-version="7.1.0"; resolution:="optional"
         Bundle was not resolved because of a uses contraint violation.
  org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.bonitasoft.studio.designer [osgi.identity; osgi.identity="org.bonitasoft.studio.designer"; type="osgi.bundle"; version:Version="7.2.3.201604291519"; singleton:="true"] because it is exposed to package 'com.fasterxml.jackson.core' from resources com.fasterxml.jackson.core.jackson-core [osgi.identity; osgi.identity="com.fasterxml.jackson.core.jackson-core"; type="osgi.bundle"; version:Version="2.5.3"] and com.fasterxml.jackson.core.jackson-core [osgi.identity; osgi.identity="com.fasterxml.jackson.core.jackson-core"; type="osgi.bundle"; version:Version="2.4.4"] via two dependency chains.

Chain 1:
  org.bonitasoft.studio.designer [osgi.identity; osgi.identity="org.bonitasoft.studio.designer"; type="osgi.bundle"; version:Version="7.2.3.201604291519"; singleton:="true"]
    require: (&(osgi.wiring.bundle=com.fasterxml.jackson.core.jackson-core)(bundle-version>=2.4.4))
     |
    provide: osgi.wiring.bundle: com.fasterxml.jackson.core.jackson-core
  com.fasterxml.jackson.core.jackson-core [osgi.identity; osgi.identity="com.fasterxml.jackson.core.jackson-core"; type="osgi.bundle"; version:Version="2.5.3"]

Last one:

eclipse.buildId=unknown
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=it_IT
Framework arguments:  -Xmx2048m -Xms1024m
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -Xmx2048m -Xms1024m

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2017-07-11 17:00:58.034
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [580]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2017-07-11 17:00:58.047
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [717]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.ds 2 0 2017-07-11 17:01:28.084
!MESSAGE [SCR - WorkThread] Timeout occurred! Thread was blocked on processing [QueuedJob] WorkPerformer: org.eclipse.equinox.internal.ds.SCRManager@651274f0; actionType 1

!ENTRY org.eclipse.equinox.ds 2 0 2017-07-11 17:01:28.211
!MESSAGE [SCR] Enabling components of bundle org.talend.amc did not complete in 30000 ms 

!ENTRY org.eclipse.core.runtime 4 0 2017-07-11 17:01:33.374
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Unable to acquire the state change lock for the module: osgi.identity; osgi.identity="org.eclipse.core.runtime"; type="osgi.bundle"; version:Version="3.10.0.v20140318-2214"; singleton:="true" [id=8] STARTED [STARTED]
	at org.eclipse.osgi.container.Module.lockStateChange(Module.java:329)
	at org.eclipse.osgi.container.Module.start(Module.java:389)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)

 

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Talend Studio sometimes does't start: could not resolve some module

Hi,

With your MDM and Dataquality licensed solution, would you mind creating a case on talend support portal so that we can give you a remote assistance(webex) to see if it is a bug through support cycle with priority?

https://login.talend.com/support-login.php.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
3 REPLIES
Moderator

Re: Talend Studio sometimes does't start: could not resolve some module

Hello,

Are you using talend subscription solution V 6.3 with bonita license?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Talend Studio sometimes does't start: could not resolve some module

Yes. MDM and Dataquality licensed

Moderator

Re: Talend Studio sometimes does't start: could not resolve some module

Hi,

With your MDM and Dataquality licensed solution, would you mind creating a case on talend support portal so that we can give you a remote assistance(webex) to see if it is a bug through support cycle with priority?

https://login.talend.com/support-login.php.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.