Talend Open Studio 6.0.0 crashing

Platform:Ubuntu 12.04.5 LTS
Java:jdk1.7.0_09
Getting the following error:
(TOS_DI-linux-gtk-x86:14583): Gdk-WARNING **: The GDK_NATIVE_WINDOWS environment variable is not supported in GTK3.
See the documentation for gdk_window_ensure_native() on how to get native windows.
TOS_DI-linux-gtk-x86: /build/buildd/oxygen-gtk3-1.0.2/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.
Aborted (core dumped)
Not sure where to go from here.  Any thoughts?
Thanks
Peter
3 REPLIES
Moderator

Re: Talend Open Studio 6.0.0 crashing

Hi Peter,
TOS_DI-linux-gtk-x86:14583): Gdk-WARNING **: The GDK_NATIVE_WINDOWS environment variable is not supported in GTK3.
See the documentation for gdk_window_ensure_native() on how to get native windows.
TOS_DI-linux-gtk-x86: /build/buildd/oxygen-gtk3-1.0.2/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.
Aborted (core dumped)

Are you using 32 bit Ubuntu 12.04.5 LTS?
Have you already installed XUL Runner package?TalendHelpCenter:Installing the XULRunner package (for Linux users)
Does this issue repro on your other old studios(5.5.x)?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: Talend Open Studio 6.0.0 crashing

Hi Peter,
TOS_DI-linux-gtk-x86:14583): Gdk-WARNING **: The GDK_NATIVE_WINDOWS environment variable is not supported in GTK3.
See the documentation for gdk_window_ensure_native() on how to get native windows.
TOS_DI-linux-gtk-x86: /build/buildd/oxygen-gtk3-1.0.2/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.
Aborted (core dumped)

Are you using 32 bit Ubuntu 12.04.5 LTS?
Have you already installed XUL Runner package?TalendHelpCenter:Installing the XULRunner package (for Linux users)
Does this issue repro on your other old studios(5.5.x)?
Best regards
Sabrina

Yes I am using 32 bit Ubuntu 12.04.5 LTS.
I have the xulrunner installed and have edited the TOS_DI-linux-gtk-x86.ini file and added the line -Dorg.eclipse.swt.browser.XULRunnerPath=/home/pdiazdeleon/ETL/Talend/xulrunner to it. 
Version 6.0.0 still crashes

I am also able to run
"Talend Open Studio for Data Integration"
Version: 5.6.1 Build id: V5.6.1_20141207_1530
and
Version: 5.6.2 Build id: V5.6.2_20150508_1414
without any problems.

I am only having problems running 6.0.0 and 6.1.0M1

Thanks
Peter
Moderator

Re: Talend Open Studio 6.0.0 crashing

Hi,
This issue is probably caused by GTK theme?As we known that, talend 5.6, 6.0 are based on Eclipse 4.x and so far, Eclipse 4.x is not compatible with KDE, GNOME is Ok)
Could you please try to change GTK2 theme to see if it works?
It should go to system setting-->Appearance-->GTK and change a non-oxygen-gtk GTK2 theme.
Your feedback will be preferred.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.