Talend ESB 6.5 - Apache Syncope not returning any users in Authorization page

Six Stars

Talend ESB 6.5 - Apache Syncope not returning any users in Authorization page

Hi there,

 

We are using Apache Syncope to retrieve users and groups from Azure AD (with ConnId). It works fine.

Then the idea is to only give access for some of our Rest and/or Soap webservice to specific groups in the organisation.

 

So in the authorization page, after creating the ressources, TAC can only display randomly the first 10-15 groups which is annoying when you have more than that. Is there a way to increase the number of roles in the view? The workaround was to actually stop sync the group. Then create manually fewer group and assign manually users into each groups but it looses the Azure AD sync.

 

Anyway, the the main issue is after clicking on the roles, the TAC doesnt show anymore any attached users even if there are users attached to the groups. Which sequentially breaks the authorisation - but not authentication. Tried on different browser and after clearing cache still no luck.

 

The core-rest.log (and other logs) doesnt show anything even if you turn the log level to trace (on CFX and REST) and going to the rest-api manually doesnt provide much more (nothing is return - /syncope/rest/groups/{key} or /syncope/rest/groups/{key}/members).

What could be the next steps to debug?

Cheers,

Moderator

Re: Talend ESB 6.5 - Apache Syncope not returning any users in Authorization page

Hello,

Here is an Architecture-Best-Practices article about

https://community.talend.com/t5/Architecture-Best-Practices-and/Enabling-SAML-Authentication-and-Aut...

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.