Talend DI startup error on Mac

Four Stars

Talend DI startup error on Mac

I've downloaded Talend DI 7.0.1 for Mac, and it freezes in the first license agreement screen. My System is MacOS High Sierra 10.13.4, with Java 1.8_172.

 

I've also tried with older Talend DI versions I had in notebooks (6.4.1, 6.5.1), and different Java versions (1.8_152, 1.7, Java 10), but always freezes in the first screen (license screen with is a new installation, or the project selection screen for older versions)

 

The log at workspace/.metadata/.log says

 

!SESSION 2018-04-22 14:33:53.798 -----------------------------------------------

eclipse.buildId=unknown

java.version=1.8.0_172

java.vendor=Oracle Corporation

BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=es_ES

Framework arguments:  -keyring /Users/czuriaga/.eclipse_keyring -showlocation

Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/czuriaga/.eclipse_keyring -showlocation

 

!ENTRY org.eclipse.compare.win32 4 0 2018-04-22 14:33:54.589

!MESSAGE FrameworkEvent ERROR

!STACK 0

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32 [226]

  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"

 

at org.eclipse.osgi.container.Module.start(Module.java:434)

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

 

Any idea about how to solve this issue?


Accepted Solutions
Moderator

Re: Talend DI startup error on Mac

Hello,

Could you please check this jira issue:https://jira.talendforge.org/browse/TUP-18888 to see if the solution mentioned in comments works for you?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: Talend DI startup error on Mac

Hello,

Could you please check this jira issue:https://jira.talendforge.org/browse/TUP-18888 to see if the solution mentioned in comments works for you?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Talend DI startup error on Mac

Solved!!

 

I had tried different JDK's (1.8_152, 1.8_172, Java 10), and different Talend DI versions (7.0.1, 5.5.1, 5.4.1), but nothing worked

 

Following that jira issue, I've installed JDK 1.8_151.

 

Only setting the environment variable JAVA_HOME to this new version, is not enough. Adding a -vm option in TOS_DI-macosx-cocoa.ini does not work.

 

I have had to modify the     TOS_DI-macosx-cocoa.app/Contents/Info.plist    adding a line to force the JDK 1.8_151

 

    <key>Eclipse</key>

            <array>

                        <string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/java</string>

                        ...

            </array>

 

 

Thank you very much for your help!

Four Stars

Re: Talend DI startup error on Mac

Solved!!

I had tried different JDK's (1.8_152, 1.8_172, Java 10), and different Talend DI versions (7.0.1, 5.5.1, 5.4.1), but nothing worked

Following that jira issue, I've installed JDK 1.8_151.

Only setting the environment variable JAVA_HOME to this new version, is not enough. Adding a -vm option in TOS_DI-macosx-cocoa.ini does not work.

I have had to modify the TOS_DI-macosx-cocoa.app/Contents/Info.plist adding a line to force the JDK 1.8_151

<key>Eclipse</key>
<array>
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/java</string>
...
</array>

Thank you very much for your help!