One Star

Talend DI 7.0.1 Doesn't Open

Hello,

Talend DATA INTEGRATION 7.0.1 doesn't open and it tells me to see the log file.

Here's the log file content:

!SESSION 2018-07-11 10:34:33.004 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_171
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2018-07-11 10:34:36.094
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [334]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2018-07-11 10:34:36.164
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [336]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.common.ui.runtime 4 0 2018-07-11 10:34:36.239
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.common.ui.runtime [488]
  Unresolved requirement: Require-Bundle: org.talend.libraries.dom4j-jaxen
  Unresolved requirement: Import-Package: org.eclipse.swt
    -> Export-Package: org.eclipse.swt; bundle-symbolic-name="org.eclipse.swt.gtk.linux.s390"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.s390 [419]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390))"
  Unresolved requirement: Import-Package: org.eclipse.swt.graphics
    -> Export-Package: org.eclipse.swt.graphics; bundle-symbolic-name="org.eclipse.swt.gtk.solaris.sparc"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.solaris.sparc [425]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"
  Unresolved requirement: Import-Package: org.eclipse.swt.widgets
    -> Export-Package: org.eclipse.swt.widgets; bundle-symbolic-name="org.eclipse.swt.gtk.linux.x86"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.x86 [421]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"
  Unresolved requirement: Import-Package: org.eclipse.swt.layout
    -> Export-Package: org.eclipse.swt.layout; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.ppc64 [414]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"
  Unresolved requirement: Import-Package: org.eclipse.swt.custom
    -> Export-Package: org.eclipse.swt.custom; bundle-symbolic-name="org.eclipse.swt.cocoa.macosx"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.cocoa.macosx [403]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"
  Unresolved requirement: Import-Package: org.eclipse.swt.events
    -> Export-Package: org.eclipse.swt.events; bundle-symbolic-name="org.eclipse.swt.gtk.linux.s390x"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.s390x [418]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390x))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.commons.runtime 4 0 2018-07-11 10:34:36.247
!MESSAGE FrameworkEvent ERROR
!STACK 0

Thanks in advance ! Smiley Happy

1 REPLY
Moderator

Re: Talend DI 7.0.1 Doesn't Open

Hello,

Ensure proper version of JDK is installed. For v6 of Talend products JDKv1.8 is required instead of JRE.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.