TOS-win32-x86 - "An error has occured. See the log file"

One Star

TOS-win32-x86 - "An error has occured. See the log file"

Hi, 
Apologies if there are some existing threads regarding this topic - if so i'm happy to redirect towards them.
A client of mine has experienced an issue which has prevented them from even being able to open Talend. I have had them send through the log files as the error was unexpected and completely random (to my knowledge!).
I was hoping you could help me make heads or tails of this...

!SESSION 2015-07-15 13:55:06.368 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments:  -os win32 -ws win32 -arch x86

This is a continuation of log file C:\Talend\TOS_DI-Win32-20150702_1326-V6.0.0\workspace\.metadata\.bak_6.log
Created Time: 2015-07-15 14:01:02.812

!ENTRY org.talend.platform.logging 2 0 2015-07-15 14:01:02.822
!MESSAGE 2015-07-15 14:01:02,812 WARN  org.ops4j.pax.url.mvn.internal.AetherBasedResolver  - Error resolving artifactorg.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT:Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT

!STACK 0
shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)
at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:576)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:531)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:506)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:481)
at org.talend.core.model.general.ModuleNeeded.getStatus(ModuleNeeded.java:246)
at org.talend.librariesmanager.model.ModulesNeededProvider.getUnistalledModulesNeeded(ModulesNeededProvider.java:796)
at org.talend.updates.runtime.engine.factory.PluginOptionalMissingJarsExtraUpdatesFactory.retrieveUninstalledExtraFeatures(PluginOptionalMissingJarsExtraUpdatesFactory.java:53)
at org.talend.updates.runtime.engine.ExtraFeaturesUpdatesFactory.retrieveUninstalledExtraFeatures(ExtraFeaturesUpdatesFactory.java:49)
at org.talend.updates.runtime.ui.CheckExtraFeaturesToInstallJob.run(CheckExtraFeaturesToInstallJob.java:67)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:434)
... 13 more

There are a number of other log files which I can add if necessary
Thanks in advance for your help.
Cheers,
Chris
Moderator

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi Chris,
From this error log, it seems you are facing the missing jar issue.
Is there any problem when you are installing "third party libraries"? Have you ever executed your job successfully on TOS_DI-Win32-20150702_1326-V6.0.0?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.