One Star

TOS_DI-win-x86_64 on windows 10 : An error has occured, see the log file

Hello,

 

When I install Telend on windows 10, there is an error. I installed java 9.0.4 on my pc.

 

The log file is :

!SESSION 2018-04-24 11:32:50.536 -----------------------------------------------
eclipse.buildId=unknown
java.version=9.0.4
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments:  -os win32 -ws win32 -arch x86_64

This is a continuation of log file C:\Users\student\Documents\Yufang\TOS DI\TOS_DI-20180411_1414-V7.0.1\TOS_DI-20180411_1414-V7.0.1\configuration\1524562371788.bak_0.log
Created Time: 2018-04-24 11:34:04.477

!ENTRY org.talend.designer.rowgenerator.nl 2 0 2018-04-24 11:34:04.477
!MESSAGE Could not resolve module: org.talend.designer.rowgenerator.nl [552]
  Unresolved requirement: Fragment-Host: org.talend.designer.rowgenerator
    -> Bundle-SymbolicName: org.talend.designer.rowgenerator; bundle-version="7.0.1.20180411_1414"; singleton:="true"
       org.talend.designer.rowgenerator [553]
         Unresolved requirement: Require-Bundle: org.talend.core
           -> Bundle-SymbolicName: org.talend.core; bundle-version="7.0.1.20180411_1414"; singleton:="true"
              org.talend.core [512]
                Unresolved requirement: Require-Bundle: org.talend.common.ui.runtime
                  -> Bundle-SymbolicName: org.talend.common.ui.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
                     org.talend.common.ui.runtime [488]
                       Unresolved requirement: Import-Package: org.eclipse.swt.layout
                         -> Export-Package: org.eclipse.swt.layout; bundle-symbolic-name="org.eclipse.swt.gtk.hpux.ia64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
                            org.eclipse.swt.gtk.hpux.ia64 [409]
                              Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=hpux) (osgi.arch=ia64))"
                       Unresolved requirement: Require-Bundle: org.talend.commons.runtime
                         -> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
                            org.talend.commons.runtime [490]
                              Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
                       Unresolved requirement: Import-Package: org.eclipse.swt.custom
                         -> Export-Package: org.eclipse.swt.custom; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
                            org.eclipse.swt.gtk.linux.ppc64 [414]
                              Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"
                       Unresolved requirement: Import-Package: org.eclipse.swt.graphics
                         -> Export-Package: org.eclipse.swt.graphics; bundle-symbolic-name="org.eclipse.swt.gtk.aix.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
                            org.eclipse.swt.gtk.aix.ppc64 [406]
                              Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc64))"
                       Unresolved requirement: Import-Package: org.eclipse.swt
                         -> Export-Package: org.eclipse.swt; bundle-symbolic-name="org.eclipse.swt.gtk.linux.x86_64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
                            org.eclipse.swt.gtk.linux.x86_64 [423]
                              Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"
                       Unresolved requirement: Import-Package: org.eclipse.swt.widgets
                         -> Export-Package: org.eclipse.swt.widgets; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
                       Unresolved requirement: Import-Package: org.eclipse.swt.events
                         -> Export-Package: org.eclipse.swt.events; bundle-symbolic-name="org.eclipse.swt.gtk.linux.x86_64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2018-04-24 11:34:04.477
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.x86 [225]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.talend.repository.ftp 2 0 2018-04-24 11:34:04.492
!MESSAGE Could not resolve module: org.talend.repository.ftp [723]
  Unresolved requirement: Require-Bundle: org.talend.core.runtime
    -> Bundle-SymbolicName: org.talend.core.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
       org.talend.core.runtime [509]
         Unresolved requirement: Require-Bundle: org.talend.model
           -> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
              org.talend.model [709]
                Unresolved requirement: Require-Bundle: org.talend.commons.runtime
                  -> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
                     org.talend.commons.runtime [490]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.talend.repository.view.di 2 0 2018-04-24 11:34:04.492
!MESSAGE Could not resolve module: org.talend.repository.view.di [739]
  Unresolved requirement: Require-Bundle: org.talend.commons.ui
    -> Bundle-SymbolicName: org.talend.commons.ui; bundle-version="7.0.1.20180411_1414"; singleton:="true"
       org.talend.commons.ui [492]
         Unresolved requirement: Require-Bundle: org.talend.utils
           -> Bundle-SymbolicName: org.talend.utils; bundle-version="7.0.1.20180411_1414"
              org.talend.utils [755]
                Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
                  -> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.23.0"
                     org.talend.daikon [515]
                       Unresolved requirement: Import-Package: org.ops4j.pax.url.mvn.internal; resolution:="optional"
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
                       Unresolved requirement: Import-Package: com.fasterxml.jackson.databind.node; version="[2.9.0,3.0.0)"; resolution:="optional"
                         -> Export-Package: com.fasterxml.jackson.databind.node; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.core,com.fasterxml.jackson.core.base,com.fasterxml.jackson.databind,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.util"
                            com.fasterxml.jackson.core.jackson-databind [15]
                              Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
                       Unresolved requirement: Import-Package: com.fasterxml.jackson.databind; version="[2.9.0,3.0.0)"; resolution:="optional"
                         -> Export-Package: com.fasterxml.jackson.databind; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.annotation,com.fasterxml.jackson.core,com.fasterxml.jackson.core.filter,com.fasterxml.jackson.core.format,com.fasterxml.jackson.core.io,com.fasterxml.jackson.core.type,com.fasterxml.jackson.databind.annotation,com.fasterxml.jackson.databind.cfg,com.fasterxml.jackson.databind.deser,com.fasterxml.jackson.databind.deser.impl,com.fasterxml.jackson.databind.introspect,com.fasterxml.jackson.databind.jsonFormatVisitors,com.fasterxml.jackson.databind.jsonschema,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.jsontype.impl,com.fasterxml.jackson.databind.node,com.fasterxml.jackson.databind.ser,com.fasterxml.jackson.databind.ser.impl,com.fasterxml.jackson.databind.type,com.fasterxml.jackson.databind.util"



1 REPLY
Moderator

Re: TOS_DI-win-x86_64 on windows 10 : An error has occured, see the log file

Hello,

We are not yet targeting Java 9.  What dependencies you have that requires JRE 9? Could you please use oracle JDK 1.8 to see if it works?

Here is online document about:TalendHelpCenter:Compatible Java Environments

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.