Four Stars

TOS DI On OSX Sierra

Hi Folks,

 

Having some trouble installing this, which is not a good start when I'm trying to sell it internally.

I've got Java 8 installed, I've tried the xattr command, I've tried installing unzipping with Keka, I've tried putting it all under /Applications/

Still no joy, here's the log.

 

2 REPLIES
Four Stars

Re: TOS DI On OSX Sierra

After reading the log more carefully,  I was curious about:

java.version=9

 

I was certain everything was still using 1.8.x ... after digging, it seems I do have Java 9 installed in /Library/Java/JavaVirtualMachines/

I tried setting JAVA_HOME and whatnot, but its a pain to set globally on Mac's so I ended up vandalizing:

sudo vi TOS_DI-macosx-cocoa.app/Contents/Info.plist

Per the inline comments, set the "-vm" option and pointed it to my JDK 1.8.0 and amazingly it now starts.

 

It can only get easier from here right ? Smiley Happy

Moderator

Re: TOS DI On OSX Sierra

Hi,

Thanks for sharing your solution with us on forum.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.