Four Stars

TOS DI 6.4 installation doesn't work on OSX El Capitan

I'm trying to install TOS DI 6.4 on OS X El Capitan 10.11.6 but can't seem to figure out what's going wrong.

 

I just downloaded the zip from here, unzipped the package then tried to launch TOS_DI-macosx-cocoa.app. Talend doesn't launch, and instead I get an error popup with a reference to the attached log file full of errors.

 

In case this is useful, I'm using jenv to manage my java versions, and my global configuration points to jdk oracle64-9.0.1.

 

Any hints are appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Four Stars

Re: TOS DI 6.4 installation doesn't work on OSX El Capitan

Hi Sabrina,
Thank you for replying.

In fact I just managed to fix the issue, simply switching to java 8 did not actually work, I had to edit the Info.plist file under the .app package, and uncomment the vm tag to make it point to the java 8 binary. This is apparently a macOS only issue when there're multiple jdk versions installed.
4 REPLIES
Four Stars

Re: TOS DI 6.4 installation doesn't work on OSX El Capitan

I tried launching the executable under the .app package from terminal and I get the following error:

Version 1.7.0_80 of the JVM is not suitable for this product. Version: 1.8 or greater is required.

 

java -version returns the below:

 

java version "9.0.1"
Java(TM) SE Runtime Environment (build 9.0.1+11)
Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

echo $JAVA_HOME returns:

/Library/Java/JavaVirtualMachines/jdk-9.0.1.jdk/Contents/Home

 

and jenv versions returns:

system
  1.8
  1.8.0.151
  1.8.0.45
  9.0
  9.0.1
  oracle64-1.6.0.41
  oracle64-1.7.0.80
  oracle64-1.8.0.151
  oracle64-1.8.0.45
* oracle64-9.0.1 (set by /Users/alayouni/.jenv/version)

 

Moderator

Re: TOS DI 6.4 installation doesn't work on OSX El Capitan

Hello,

So far, oracle java 9 is not list on compatible java environment.

Please have a look at this online document about:TalendHelpCenter:Compatible Java environments.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: TOS DI 6.4 installation doesn't work on OSX El Capitan

Hi Sabrina,
Thank you for replying.

In fact I just managed to fix the issue, simply switching to java 8 did not actually work, I had to edit the Info.plist file under the .app package, and uncomment the vm tag to make it point to the java 8 binary. This is apparently a macOS only issue when there're multiple jdk versions installed.
Moderator

Re: TOS DI 6.4 installation doesn't work on OSX El Capitan

Hello,

Great, your issue has been fixed. Thanks for sharing your solution with us.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.