TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Six Stars

TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Hi,

I work with TOS free edition under windows OS since 4.1.2.

Now i am migrating to 6.0 and to LINUX DEBIAN OS. Migration from 4.1.2 to 6.0 was made under windows version and is ok. After that i have exported my projet and imported it under LINUX version. I have a problem with NLS parameters (i user ORACLE database). in .bash_profile there are export commands to initialise NLS_LANGUAGE and NLS_DATE_FORMAT. I've verified, variables are ok. But when i am in TOS and i query NLS session parameters table, the values are not set to the same values.

In fact TOS doesn't use linux session parameters. Why ? How can i do ?

Thank you for any information.

Yannick


Accepted Solutions
Six Stars

Re: TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Hi,

i first modified the talend ini file but i didn't work. I added parameters into talend preference/talend/exec/debug and then it worked in talend (metadata schem update) and job run.

thank you


All Replies
Six Stars

Re: TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Hi Abelya,

 

On Linux, JDBC connection doesnt pickup NLS from NLS variable but either by deriving the "locale" of the system / https://linux.die.net/man/1/locale or if you want your system to be in a different locality comparing to your DB connection you will need to specify it at either JVM instantiation

java -Duser.language=FR -Duser.country=FR (can be done at RUN => Advanced Settings)

or

LC_ALL=en_US.UTF-8 java (will be tricky with Talend)

 Generally speaking, you should have a look there https://docs.oracle.com/javase/8/docs/api/java/util/Locale.html

Tags (1)
Six Stars

Re: TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Hi Adrien,

I will test -d parameteres in the ini file from TALEND as soon as i have the update rights on the file. I'll tell you the reasult.

Thank you

Yannick

Six Stars

Re: TOS DI 6.0 doesn't use NLS session parameters under LINUX DEBIAN

Hi,

i first modified the talend ini file but i didn't work. I added parameters into talend preference/talend/exec/debug and then it worked in talend (metadata schem update) and job run.

thank you