Four Stars

TAC 7.0.1 Nexus with context path

Hi,

We're currently in the process of upgrading our installation. Tac seems to have a problem having the context "/nexus" to the URL.

To reproduce the issue, simply set the URL "https://example.com/nexus/" in Configuration > User Libraries. The resulting error will show the URL with the missing "/nexus" part (Unexpected HTTP status '411' when accessing (https://example.com/service/rest/v1/script/healthCheck/run)).

As a workaround, we'll probably set the context to something else than "nexus" (probably "nexus3") which doesn't cause the issue. Using a different dedicated domain/subdomain and removing the context would also work.

I'm not quite sure how I should report this issue, but I hope this can help others.

Thanks

Matt

3 REPLIES
Moderator

Re: TAC 7.0.1 Nexus with context path

Hello,

You are able to connect to nexus fine via URL and set up repositories?

On the TAC configuration page for the Artifact Repository in the "Nexus url" field, the default URL of Nexus repository is http://<hostname>:8081/nexus.

It's recommended that you create a case on talend support portal so that our colleagues from support team will check it to see if it is a bug on 7.0.1 through support cycle with priority.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: TAC 7.0.1 Nexus with context path

Yes, I was able to connect to Nexus fine with the URL. I ended up setting up Nexus on a sub domain and it now works.

 

I will check into reporting this issue.

 

Thanks

Moderator

Re: TAC 7.0.1 Nexus with context path

Hello,

Please feel free to let us know if there is no response from talend support team.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.