Problem with "Calling a Web service in Talend Studio"

Five Stars

Problem with "Calling a Web service in Talend Studio"

Hi,
I have used the example « Calling a Web service in Talend Studio » present in the « Talend Help Center » but I meet a problem when I execute this job and I do not know what to do.
Démarrage du job CallPublicWebService a 14:24 28/03/2017.
connecting to socket on port 3431
connected
Exception in thread "main" java.lang.NoClassDefFoundError: javax/wsdl/extensions/mime/MIMEContent
         at org.apache.axis.wsdl.gen.Parser.run(Parser.java:297)
         at org.talend.DynamicInvoker.<init>(DynamicInvoker.java:111)
         at org.talend.DynamicInvoker.main(DynamicInvoker.java:189)
         at org.talend.DynamicInvoker.main(DynamicInvoker.java:131)
         at premierprojet.callpublicwebservice_0_1.CallPublicWebService.tFixedFlowInput_1Process(CallPublicWebService.java:770)
         at premierprojet.callpublicwebservice_0_1.CallPublicWebService.runJobInTOS(CallPublicWebService.java:1269)
         at premierprojet.callpublicwebservice_0_1.CallPublicWebService.main(CallPublicWebService.java:1126)
Caused by: java.lang.ClassNotFoundException: javax.wsdl.extensions.mime.MIMEContent
         at java.net.URLClassLoader.findClass(Unknown Source)
         at java.lang.ClassLoader.loadClass(Unknown Source)
         at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
         at java.lang.ClassLoader.loadClass(Unknown Source)
         ... 7 more
disconnected
Job CallPublicWebService terminé à 14:24 28/03/2017.
 
Thank you for your help. I am a novice user of Talend J
 
 
Moderator

Re: Problem with "Calling a Web service in Talend Studio"

Hi,
From the exception message, there is a missing jar issue in your job.
Have you already successfully installed the external required jar file(wsdl4j.jar) in your job?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Problem with "Calling a Web service in Talend Studio"

Hi,
Thank you for your response.
I have installed the external jar file "wsdl4j-1.6.3-sources.jar". And in the list of modules, all modules required is ok
Perhaps, it isn't the good file ?
what is the procedure to uninstall a file jar before a new install ?
Best regards
Moderator

Re: Problem with "Calling a Web service in Talend Studio"

Hi,
Have you tried to restart your studio to see if it works after install the external jar file "wsdl4j-1.6.3-sources.jar"? What's talend build version you are using?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Problem with "Calling a Web service in Talend Studio"

Hi,
Yes, I restarted my VM but the result is the same
The version used, is 6.3.1 and downloaded file is "_TOS_DI-20161216_1026-V6.3.1.zip"
Best Regards
Philippe