Pb during install of TOS-DI-20161216_1026-V6.3.1

One Star

Pb during install of TOS-DI-20161216_1026-V6.3.1

  Hello,
  when i try to run the script TOS_DI-linux-gtk-x86.sh on a Linux X86_64, i got these messages :
!SESSION 2017-01-23 13:49:11.848 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=fr_FR
Command-line arguments:  -os linux -ws gtk -arch x86_64
!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2017-01-23 13:49:12.981
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
        at org.eclipse.osgi.container.Module.start(Module.java:434)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.jdt.launching.macosx 4 0 2017-01-23 13:49:13.000
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
...

  What i'm doing wrong ???
Moderator

Re: Pb during install of TOS-DI-20161216_1026-V6.3.1

Hi,
What's the linux version you are using? Have you already checked online document about:TalendHelpCenter:Compatible Operating Systems to see if you are on the compatible platforms?
Have you already installed the XULRunner package on your linux?
TalendHelpCenter:Installing the XULRunner package
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Pb during install of TOS-DI-20161216_1026-V6.3.1

  Hello,
  OS : CentOS Linux release 7.3.1611 (Core)
  I've already check multiple time the documentation (and search a lot on the internet too). But, i think i can have make a mistake somewhere ...
  My version of the xulrunner is :
BuildID=20150320202338
Milestone=36.0.4
SourceStamp=df45b1c67169
  I've installed the package gtk2-2.24.28-8.el7.i686 (exist only in i686 version on my centos ...) which contain the libgtk-x11-2.0.so.0 file.
  Thank you for your help.
One Star

Re: Pb during install of TOS-DI-20161216_1026-V6.3.1

  Hello again,
  i change my xulrunner version. I try 2 differents versions, but stil have the same message ... Do we have to choose a version i686 or x86_64 of xulrunner ?
  And second question, is it normal that the enviroenment (gtk ...) is in i686 only version and TOS in X86_64 ?
  Thank you.
One Star

Re: Pb during install of TOS-DI-20161216_1026-V6.3.1

 I've found the origin of my problem.
  It was a centos 7 without Gnome Desktop environment and Eclipse.
  Now, the first launch seem to work (i'm on the choice of optionals packages ...).
Thanks.