No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Five Stars

No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Me and my whole (backoffice) team can't seem to succesfully install and download Talend.

Also our ICT-department has looked into it but has given up.

We have tried multiple versions and also multiple version of Java but still no luck.

 

Who's the hero that's gonna save my day?

Six Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Hi Evvliet,

 

What version of Talend are you referring to? Open Source or suscription? Is it Talend Data Integration or a different module?

 

When you say download, are you talking about the self installer that will then download the software or you are talking about the installer itself?

 

The version 6.5 of Talend works with v1.8 of Java (didnt work at all on v1.9 and havent tried v1.10).

 

And finally, is there any specific error or it is just stuck somewhere?

 

Five Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Hi AdrienAussie,

 

I'm referring to Open Source and Talend Data Integration.

I have downloaded the zip.file (we work on Mac) and have unzipped it, after that I have understood I am to use the TOS-file but nothing happens when doing that.

 

I have had someone from IT coming over and trying to install both the newest versions of Talend & Java. And when that didn't work we tried using 6.1.2 with Java 1.8 #131, since those were the versions a former collegue of us worked with. 

 

He's left and now all 5 of us want to start learning to work with Talend... but getting it local seems to be our greatest challenge so far.

 

Hope that answers all of your question.s

 

Greetings,

Esther.

Six Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Hi Esther,

Yes it gives a bit of direction. Did you setup the JRE_Home and Java_Home path variable to begin with? If not, I usually recommend this link https://www.mkyong.com/java/how-to-set-java_home-environment-variable-on-mac-os-x/

When you say that nothing happens, you mean you don't even get a splash screen or a crash or any errors?

Anyway, Java 8 #132 and Talend 6.5.1 or new Version 7.0.1 are a good match so no issues on that end.

Usually on Mac, you have to disable a verification on executable that come from the Web (trusted macosx program). It is described here: http://www.idownloadblog.com/2017/04/20/fix-application-from-internet-gatekeeper/

Did you try the indication of that post
https://community.talend.com/t5/Installing-and-Upgrading/Installing-Talend-ESB-6-4-1-on-mac-osx-10-1...
, the last part with xattr is about TOS 6.5 and resumed pretty well all the issues that I have on Mac before?

On a different note, if you gonna be 5 working on the same project moving forward, it might be good to look at the advantages of the subscription version such a collaboration.

Cheers,
Adrien
Five Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Hey there Adrian,

 

Me and my colleque used your suggestions and there seems to be some sort of succes, the screen I get the attached screenshot.

Clicking 'I accept' results in endless waiting.

 

Six Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

From the others, it seems that only Java JDK 1.8.151 is working with Talend on latest Mac Sierra.

 

It can found at the bottom at the page:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html?printOnly=...

Change the JRE and JAVA_HOME and reboot after retrying to go forward.

 

If it is not working, are you able to share your log file ?

 

It would be nice to have a Talend representative to pass that to R&D as java 1.8 will be retiring in less than a year and they will need to address it (probably move to java 1.10 as 1.9 is flaky). It is quite odd that Eclipse can only work with #151.

Six Stars

Re: No luck (for our whole team) after hours, days and weeks installing Talend Data Intregration

Actually Talend already a logged case for that:

 

https://jira.talendforge.org/browse/TUP-19313

 

It confirms that only version 151 of Java is supported on Mac (later version arent).