Five Stars

Nexus 3 is not supported by TAC 7.0

Hello guys,

 

We've recently installed Talend 7.0.1 by a Talend expert (he actually works for Talend) with nexus oss 3.9 on a development environment.

Unfortunately we couldn't publish our artifacts from the Talend administration center (Publisher). It says "You have selected Nexus 3 as the artifact repository. This version is not supported by Publisher. To use Publisher, change the repository to Nexus 2."

The problem is that Nexus 2 is not suggested in the configuration page of the TAC. only Nexus and Nexus 3 as type.

Should I install the Nexus v2.x.x or is there something to configurate to work?

Note: I can publish my artifacts from Talend studio.

See the pictures for more details.

 

Best regards.

 

Amine  

1 ACCEPTED SOLUTION

Accepted Solutions
Five Stars

Re: Nexus 3 is not supported by TAC 7.0

Hello guys,

 

this is the Talend reply about the subject.

 

The ESB publisher is deprecated and will be dropped in the future, that's why they didn't upgrade it to accept the nexus 3. So they adviced me to let the nexus 3 installed and publish from the studio, or installing the Talend CI builder and use the continuous integration way.

 

I hope this has been beneficient for you.

 

Best regards.

 

Amine

 

 

6 REPLIES
Fifteen Stars

Re: Nexus 3 is not supported by TAC 7.0

Your Talend Expert should either be able to help you or be getting R&D on the case immediately if this is the case. I'm afraid I have not come across this, but it sounds like a bug and should be reported.

Rilhia Solutions
Employee

Re: Nexus 3 is not supported by TAC 7.0

The TAC dropdown NEXUS refers to Nexus 2 and you have to install it yourself.

 

The limitation applies only to Publisher. Publisher is also deprecated and we recommend to use the Maven based CI approach supporting Nexus 3.

Thomas Steinborn
VP Product Management
Four Stars

Re: Nexus 3 is not supported by TAC 7.0

I have this same issue.  I just installed Talend 7.0.1 on a new server and Publisher wont work for me unless I change the drop down to Nexus.  The default it is set to Nexus 3.  Once I change it to Nexus, I can then publish from Studio on my PC up to TAC.

 

If your saying not to use Publish, can you explain how to use Maven from Studio and from Job Conductor?  Do I have to reinstall TAC to do that?  If publisher inst suggested, it really should be in the install suggesting Maven instead.

Five Stars

Re: Nexus 3 is not supported by TAC 7.0

It's a pitty to not be informed by the Talend expert, it gives them a bad reputation.

 

I'am not an administrator tu use the maven CI, I can only use the TAC to publish.

 

I will call the Talend support next week.

 

thanks for your reply.

Four Stars

Re: Nexus 3 is not supported by TAC 7.0

i have never heard a bug like this , but i am preety sure that
the talentd community will resolve this issue once you call them!
good day
Five Stars

Re: Nexus 3 is not supported by TAC 7.0

Hello guys,

 

this is the Talend reply about the subject.

 

The ESB publisher is deprecated and will be dropped in the future, that's why they didn't upgrade it to accept the nexus 3. So they adviced me to let the nexus 3 installed and publish from the studio, or installing the Talend CI builder and use the continuous integration way.

 

I hope this has been beneficient for you.

 

Best regards.

 

Amine