Missing Jar references

One Star

Missing Jar references

Hi folks, this may be a noob question so apologies in advance and yes I did search.
I tried a quick test in the Data Integration Studio (5.1) and quickly got the tFileInputDelimited connector moving data to a tFileOutputDelimited connector. No problem there.
I then tried the tFileInputDelimited connector with the same input file in the Big Data Studio (5.1) and I'm facing an issue:
1. "Built-In" is greyed out so I cannot select "Repository" to have the file generate the schema.
2. The app is complaining that "javacsv.jar" is required but not loaded.
All I'm trying to do is get a CSV file uploaded to my Cloudera Hadoop VM HDFS.
Any ideas why my tFileInputDelimited connector is behaving so differently between Data Integration Studio and Big Data Studio???
Thanks!
One Star

Re: Missing Jar references

Hi
Welcome to Talend Community!
I try to reproduce this issue with TOS for BD 5.1, but failed.
Please upload some images about your job and this issue.
Regards,
Pedro
One Star

Re: Missing Jar references

Thanks Pedro. Here are some pics. 1 showing the greyed out and the other showing the error tab. Please let me know if there is anything else I can upload that would be useful.


One Star

Re: Missing Jar references

Apparently image tags aren't working. I'm guessing this is the 10 post limitation?
One Star

Re: Missing Jar references

Also... I opened up the demo and it has the same issue in the file examples:
One Star

Re: Missing Jar references

Hi
Now the workaround is if you have other versions of TOS, just copy this jar file into <TOS for BD installation dir>\lib.
Regards,
Pedro
One Star

Re: Missing Jar references

Hi Pedro --
I installed the new version today and it worked. Thanks for all of your help.
Wes
One Star

Re: Missing Jar references

I am getting "org.talend.commons.exception.CommonExceptionHandler  - Missing jars: jconn3.jar" error when using Talend commandline. I have jconn.jar in <TalendHome>/lib/java. I got upgrade from 5.5.1 to 6.1.1 recently. I never have a problem in 5.5.1.