Migration 4.2.3 to 5.1.x and version selection

One Star

Migration 4.2.3 to 5.1.x and version selection

Hi everyone,
We are going to migrate our TIS 4.2.3 to 5.1.x version.
Could you tell me differences beetwen 5.1.2 and 5.1.3 ? and which one we should choose ?
And could you give me a feedback of your migration ?
Thanks in advance.
Regards,
Marc
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
We are going to migrate our TIS 4.2.3 to 5.1.x version.
Could you tell me differences beetwen 5.1.2 and 5.1.3 ? and which one we should choose ?
And could you give me a feedback of your migration ?

Due to it refers to Talend Enterprise Subscription Version Upgrade, it suggested that you can report a ticket on talend support portal, our colleagues from support team will give you a help for your requirement.
Note: In your case, the type of your ticket should be "migration".
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hello,
I want to make the migration from version 4.0 to 5.0 of talend. Can someone tell me what are the steps to follow?
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
I want to know, how to migrate talend V4.0 to talend V5.0 ?
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
For community version migration, you need export your project developed in V4.0. How to export a project, and then import the project into V5.0 . How to import projects.
Upgrading your Talend products
Note:Talend forbid import of items from an upper version.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Migration 4.2.3 to 5.1.x and version selection

HI Sabrina
Your link is really helpful for migration , let me add a quick question to it :
we can directly export job "Export items to an archive file or directory." as archive file with all dependencies and import to subsequent version(higher version). Is this way is going to give an error in migration in near future?
We made migration of some projects by this way and we are not sure whether it is going to give any error in near future presently it is working well and we dont have any custom components.
From
TalendDataQuality Enterprise Edition (4.2.3.r67267) to Talend Plateform for Data Managerment(5.2.1.r95165)
thanks
Anil Kumar Burri
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
we can directly export job "Export items to an archive file or directory." as archive file with all dependencies and import to subsequent version(higher version). Is this way is going to give an error in migration in near future?
We made migration of some projects by this way and we are not sure whether it is going to give any error in near future presently it is working well and we dont have any custom components.

It is also correct without error. "Export a project" can export many projects at the same time. "Export items to an archive file or directory." just export the current project. I think it is up to your work situation.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Migration 4.2.3 to 5.1.x and version selection

HI Sabrina
thank you, your quick response is really helpful because we are currently working on migration of many developed projects
Best regards
Anil Kumar Burri
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
You are welcome. Feel free post your issue on forum.
In addition, for community version, you can just migrate the custom component item into new studio. If you use it in job design, you need reinstall the custom component into new studio.
Certainly, for enterprise subscription version, these custom component can be shared. Sharing custom components.
Hope it will be useful for your work.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

thank you very much for your help sabrina.
I have another question, my projects developped as talend 4.0 is that it will be a problem when migrating in talend 5.0? if yes. what are the problems and solutions.
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
I have another question, my projects developped as talend 4.0 is that it will be a problem when migrating in talend 5.0? if yes. what are the problems and solutions.

It is allowed migrate the talend 4.0 to talend V5.0. That's upgrade process. Talend forbid import of items from an upper version that means you cannot import the job developed by talend V5.0 into talend 4.0. Because in upper version, there may be some new features or new changes which cannot be used in older version.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Thank you for your confirmation sabrina,
I have noticed that there are SEVERAL versions talend 5.0. I worked with talend open studio 4.0 (open data solution) and I intend to migrate my projects talend Talend ESB version 5.0 is an Enterprise Service Bus (ESB), but I'm not sure of my choice. databases I often wonder what is oracle. you advise me which version talend Sabrina (ESB or integration of data or MDM or QUality data)?
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
I have noticed that there are SEVERAL versions talend 5.0. I worked with talend open studio 4.0 (open data solution) and I intend to migrate my projects talend Talend ESB version 5.0 is an Enterprise Service Bus (ESB), but I'm not sure of my choice. databases I often wonder what is oracle. you advise me which version talend Sabrina (ESB or integration of data or MDM or QUality data)?

What's your version of talend V4.0, is it talend open studio for ESB? If so, you can migrate it into talend Talend ESB version 5.0.
(If your talend V4.0 is open studio for data integration or others, you can also migrate it into Talend ESB version 5.0, however, perhaps some components cannot be displayed ). Different products DI, ESB, MDM, BigData and Data Qulity have their own components in studio.
For oracle DB, you can go to the oracle official website for more information http://www.oracle.com/index.html
We just forbid import of items from an upper version: 4.x.x-->5.x.x OK, 5.x.x-->4.x.x No (not the product type DI, MDM,ESB...)
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

my version of Talend's open data solutions, Open Studio Version: 4.0.0, but I do not know what kind of talend version 5.0 must be used to open data solution talend?
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: org.eclipse.emf.ecore.xmi.UnresolvedReferenceException: Unresolved reference '_8oHZs4E5EeCi8M8pA6tRqA'. (platform:/resource/INTERFACE_HR_VERS_ASTRE/talend.project, 264, 239)

It seems that something wrong with your source project(/resource/INTERFACE_HR_VERS_ASTRE/talend.project). Could you use "Export items to an archive file or directory." option to export your current job and then import it into the v5.3.0vversion ESB talend open studio so see if this issue repro again?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi Sabrina,
I did export my work in progress but probème still exists. I noticed that the new version talend ESB Version 5.3.0 when importing the project aparais not in the list of just the workspace. I need a solution for all my projects are under talend open studio 4.0.
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
What's your talend 4.0 edition? I will take a testing for you.
As we known that it is Data Integration product before 5.0. Why don't you migrate your talend 4.0 to v5.3.0 DI(Talend open studio for data integration) product not ESB?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

my version is 4.0 talend (Talend open studio open data solution).
I do not find this version (open data solution) in 5.0 so I opted for BSE. In my projects I often wonder oracles bases and I use (metadata) for creating connections. I'll download the 5.3.0 version of data integration to see what happens.
Thank you very much Sabrina
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
my version is 4.0 talend (Talend open studio open data solution).

Since talend 5.0, "Talend open studio open data solution" is changed as "Talend open studio for Data Integration" so it is DI product you used.
In my projects I often wonder oracles bases and I use (metadata) for creating connections. I'll download the 5.3.0 version of data integration to see what happens.

For DB connenction, it recommend you read the online article Setting up a DB connection with five chapters
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi Sabrina,
Thank you for your answer, I set ID and tried to import my project, I had the same problem it does not work. I do not know what to do. Smiley Sad
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: org.eclipse.emf.ecore.xmi.UnresolvedReferenceException: Unresolved reference '_8oHZs4E5EeCi8M8pA6tRqA'. (platform:/resource/INTERFACE_HR_VERS_ASTRE/talend.project, 264, 239)

That means you still have this issue? If so, I suspect the talend.project file is broken. Could you import other projects into v 5.3.0 Talend Data Integration instead of resource/INTERFACE_HR_VERS_ASTRE/talend.project, 264, 239(I suspect this project are corrupt)? I have no idea what happened to the talend.project file.
Using "Export items to an archive file or directory." to export your project one by one and import them into new studio by turn.
For the corrupt one, we need investigation. Hope it is a alternative solution for you.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Thank you so much Sabrina,
I solved the problem of import. but Now, I met another problem, I have lost the metadata on the new version 5.3.0. And if I want to import the metadata, he told me that it exists. what am I doing?
Best regards
Marwa
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
When importing project (talend 4.0) to talend (5.3.0 Data Integration), I lose the metadata schema (tMap). is there a solution for this?
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
I lose the metadata schema (tMap).

Do you mean you miss the schema setting of tMap in a specified job?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi Sabrina,
yes exactly, in the job. In addition, I have the problem with metadata. All connections create no longer exist. and if I want to import, a message tells me that they exist. what am I doing?
Best regards
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi,
All connections create no longer exist. and if I want to import, a message tells me that they exist.

Any screenshots for that? Could you please upload the screenshot of your new Talend open studio 5.3.0 to us?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

hi Sabrina,
My problem is when I open my project (created in Talend 4.0) in Talend 5.3
I can not find the connections created to access my oracle database data (metadata / bd conneixon). I have a second problem is that my settings tMap between different tables do not exist more.
My question: is there a solution, Address to receive everything, without redoing it again ?
thank you
Marwa
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi miha23,
There is a similar issue as yours, please refer to it Forum 26276, hope it will be helpful for your issue.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Migration 4.2.3 to 5.1.x and version selection

Hi Sabrina,
I migrated talend Talend DI 4.0 in version 5.3. I encountered the problem when I open my project talend in the new version. I found a change in some parameter such as, lack of metadata, and Tmap must reconfigure. My question, is there a solution for this change? because I do not want to redo my work.
Moderator

Re: Migration 4.2.3 to 5.1.x and version selection

Hi miha23,
Go to <Talend studio installation path>/workspace/project_name/process folder, and see if the job items are still there, if so, follows these steps to restore the jobs:
1. Install a new Studio or open the old Studio and change another workspace.
2. Create a new project and open it.
3. Right-click Job designs, select 'import items' option.
4. And then, browse your old workspace and import the job items.
If the jobs do disappear from the old workspace, you have to restore them from your last backup.
Is the solution not helpful for your issue? So far there is no a better solution for that. Or you have to config your tMap again and create new metadata.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.