Four Stars

MacOS High Sierra version 10.13.1 unable to install Talend data integrator

Hi,

 

I have downloaded the Talend data integrator on my Macbook (High Sierra version 10.13.1). I have also installed JVM 1.8 (which was a prerequisite).

 

When I try to run the installer "TOS_DI-macosx-cocoa" (assuming this is the correct one as the others are marked Windows and Linux), I get an error message with a log file created. The log file is really long and I am unable to determine the issue from there.

 

any suggestions to resolve this please?

 

Thanks!

4 REPLIES
Moderator

Re: MacOS High Sierra version 10.13.1 unable to install Talend data integrator

Hello,

Are you downloading talend data integration V 7.0? Coud you please upload your log file into forum which will be helpful for us to address your issue?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: MacOS High Sierra version 10.13.1 unable to install Talend data integrator

Hi,

 

Thanks for getting back and sorry for the late reply.

 

Please find the log file attached here.

Four Stars

Re: MacOS High Sierra version 10.13.1 unable to install Talend data integrator

and yes it is talend data integration V 7.0

 

Thanks!

Moderator

Re: MacOS High Sierra version 10.13.1 unable to install Talend data integrator

Hello,

From your log message:

!SESSION 2018-04-29 08:50:07.319 -----------------------------------------------
eclipse.buildId=unknown
java.version=10
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_SG
Framework arguments:  -keyring /Users/harjyotkaur/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/harjyotkaur/.eclipse_keyring -showlocation

!ENTRY org.talend.hadoop.distribution.mapr600 4 0 2018-04-29 08:50:14.717
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.hadoop.distribution.mapr600 [13]
  Unresolved requirement: Require-Bundle: org.talend.core.runtime

Are you installing both java 8 and java 10 in your machine? If so, could you please

goto Window > Preferences > Java>Installed JREs, and  select Edit and browse for the appropriate JRE(JDK 1.8)

let us know if it is OK with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.