Lots of problems with metadata in Talend 7.2.1 (MacOS)

Highlighted
Four Stars

Lots of problems with metadata in Talend 7.2.1 (MacOS)

I've recently upgraded to Talend Open Studio 7.2.1 and now find that I simply can't work with metadata

 

  • Setting a repository/respositoryId in a tMap component seems to be ignored. The columns shift in the UI but the entry is blank and, once saved, the schema reverts to the old version.
  • Setting a metadata schema in an output file often results in the column order being scrambled. You can try setting it manually but when you return to a schema, the columns re-scramble. This is even when it's getting an output that uses the same schema.
  • If you run a job and it tries to reload the schemas, it often reverts to an incorrect or scrambled schema.

This is very visible when using generic schemas but also shows up with other schemas, such as delimited versions.

Tags (1)
Moderator

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hello,

Could you please have a look at this online installation guide about:TalendHelpCenter:Compatible Operating Systems to see if you are on a compatible platform?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hello,

Here exists a know issue for OS X Mojave Mac OS:

https://community.talend.com/t5/Migration-Configuration-and/Talend-Studio-crashes-on-OS-X-Mojave-Mac...

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hi Sabrina,

 

I'm running MacOS 10.14.6, which isn't on the list but is also something I have no control over.

 

I've tried adding -Dos.version=10.14 to TOS_DI-macosx-cocoa.ini but it doesn't have any effect.

 

Doug

Four Stars

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

I have the same problem with  Talend 7.2 on windows 10. 

That is a bug of the release.

I  provisionally solve using only repository metadata.

Moderator

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hello,


@charvolant wrote:

Hi Sabrina,

 

I'm running MacOS 10.14.6, which isn't on the list but is also something I have no control over.

 

I've tried adding -Dos.version=10.14 to TOS_DI-macosx-cocoa.ini but it doesn't have any effect.

 

Doug


Actually, Mac OS 10.14.6 is not supported officially by talend. So far, we just fix tMap crash issue on MacOS Mojave.

You can please give any log you have? (if crash, there might be some log in configuration folder, but maybe as well something in the standard logs workspace/.metadata/.log )

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hello @neochaotic 

What's Mac OS version are you using?

Could you please have a look at this online documentation about:TalendHelpCenter:Compatible Operating Systems to see if you are on a compatible platform?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hi @xdshi !

 

I have de same problem  with metadata and Schemas with Talend 7.2.1 using Windows 10 and JDK 1.8.

This Version broke my project before worked on 7.1. No has any error or exceptions, just schema are a mess and do not work fix the schema order.

It 's possible make downgrade to 7.1 ?

Moderator

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

Hello @neochaotic 

Could you please have a look at this jira issue:https://jira.talendforge.org/browse/TUP-23809 and let us know if it is related to your issue?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars BRM
Five Stars

Re: Lots of problems with metadata in Talend 7.2.1 (MacOS)

I am having the same issues.  I am using Win 10.

 

The issue TUP-23809 adequately describes the issue I am having but the workarounds are not working for me.  I am having the issue primarily for Redshift DBInput components. 

 

If I decide I need to add a field to the input component query I cannot change the schema to match the query, I have to change the query to match whatever TOS 7.2.1 decides to make the schema.  I have also had issues of TOS rearranging schema order downstream in the job. The only solution I have found is to re-create the job from scratch.  It seems the editing process is where it screws up.  

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 3

Read about some useful Context Variable ideas

Blog