Five Stars

License Accept dialog unresponsive on Mac OS Sierra

I installed TOS_BD 6.4.1 on Mac OS Sierra.  When I double click on the app to start it, the splash screen comes up, then the license accept dialog comes up, but is unresponsive.  The accept button is there, and blue like it is active.  I can’t proceed past this dialog.  The error is the same whether I unzipped with the Mac utility or a third party tool.  The zip archive should be ok, I tested it on a windows machine and it worked.  The log file says:

 

!SESSION 2017-11-15 21:20:25.248 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_152
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -keyring /Users/xxxx/eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/davidrosenblum/.eclipse_keyring -showlocation

!ENTRY org.eclipse.equinox.ds 4 0 2017-11-15 21:20:25.813
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.ds [4]
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.compare.win32 4 0 2017-11-15 21:20:30.296
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32 [88]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.compare.win32 4 0 2017-11-15 21:20:31.922
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32 [88]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1498)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
:

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Five Stars

Re: License Accept dialog unresponsive on Mac OS Sierra

Hi John,

 

This is a new laptop for me, so I just installed the latest JDK, which is 152 about 3 weeks ago.  Today I installed the 151 version from Oracle's site, which left me with two jdk's.  I tried changing my java home to 151 by changing my .bashrc to set JAVA_HOME to the older version like this 

export JAVA_HOME=`/usr/libexec/java_home -v 1.8.0_151`

but that didn't seem to help (I did not reboot)

 

Then I went into the app package  (right or two finger click on the app and then select show package) and changed the file Contents/info.plist as you see below.  You can list out your installed JDK's with 

/usr/libexec/java_home -V 

to get the correct path.

 

I added the line in bold to the file and saved it, and then it would start.  Your JDK or location may be different, so run the command to get list of installed versions.   The entire file is posted for completeness, but I had to rename to Info.plist.txt to do so.

 

<key>Eclipse</key>
<array>
<!-- to use a specific Java version (instead of the platform's default) uncomment one of the following options,
or add a VM found via $/usr/libexec/java_home -V
<string>-vm</string><string>/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java</string>
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/1.8.0.jdk/Contents/Home/bin/java</string>
-->
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/java</string>
<string>--launcher.ini</string>
<string>$APP_PACKAGE/../TOS_BD-macosx-cocoa.ini</string>
<string>-keyring</string><string>~/.eclipse_keyring</string>
<string>-showlocation</string>
<!-- WARNING:
If you try to add a single VM argument (-vmargs) here,
*all* vmargs specified in eclipse.ini will be ignored.
We recommend to add all arguments in eclipse.ini
-->
</array>

5 REPLIES
Moderator

Re: License Accept dialog unresponsive on Mac OS Sierra

Hello,

Could you please have a look at this online document about:TalendHelpCenter:Compatible Operating Systems to see if you are on a compatible platform?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: License Accept dialog unresponsive on Mac OS Sierra

Hi Sabrina,

 

Thank you for taking the time to look into this issue.  My exact OS is macOS Sierra Version 10.12.6.  This is listed as a Supported OS.  Is there a way I can change a file to say I clicked Accept so that things can proceed?  As I was looking around this site, I saw a reference to the version of java being a factor, so I will try 1.8 151 instead of 152. 

 

Thank you,

 

David

Two Stars

Re: License Accept dialog unresponsive on Mac OS Sierra

David,

 

I'm having the same issue as you describe.  I am also running macOS Sierra 10.12.6 and java version 1.8.0_152. 

 

I'm curious if 151 helps you in this case. My old machine was running 10.11.6 and java 1.8.0.31.  Gonna try and dig up that java version and install.

 

John

Five Stars

Re: License Accept dialog unresponsive on Mac OS Sierra

Hi John,

 

This is a new laptop for me, so I just installed the latest JDK, which is 152 about 3 weeks ago.  Today I installed the 151 version from Oracle's site, which left me with two jdk's.  I tried changing my java home to 151 by changing my .bashrc to set JAVA_HOME to the older version like this 

export JAVA_HOME=`/usr/libexec/java_home -v 1.8.0_151`

but that didn't seem to help (I did not reboot)

 

Then I went into the app package  (right or two finger click on the app and then select show package) and changed the file Contents/info.plist as you see below.  You can list out your installed JDK's with 

/usr/libexec/java_home -V 

to get the correct path.

 

I added the line in bold to the file and saved it, and then it would start.  Your JDK or location may be different, so run the command to get list of installed versions.   The entire file is posted for completeness, but I had to rename to Info.plist.txt to do so.

 

<key>Eclipse</key>
<array>
<!-- to use a specific Java version (instead of the platform's default) uncomment one of the following options,
or add a VM found via $/usr/libexec/java_home -V
<string>-vm</string><string>/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java</string>
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/1.8.0.jdk/Contents/Home/bin/java</string>
-->
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/java</string>
<string>--launcher.ini</string>
<string>$APP_PACKAGE/../TOS_BD-macosx-cocoa.ini</string>
<string>-keyring</string><string>~/.eclipse_keyring</string>
<string>-showlocation</string>
<!-- WARNING:
If you try to add a single VM argument (-vmargs) here,
*all* vmargs specified in eclipse.ini will be ignored.
We recommend to add all arguments in eclipse.ini
-->
</array>

Two Stars

Re: License Accept dialog unresponsive on Mac OS Sierra

Thanks David!

 

That worked for me as well.  Really appreciated your solution on this!

 

Thanks,
John